aboutsummaryrefslogtreecommitdiff
path: root/databases/postgis/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-12 21:01:32 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-12 21:01:32 +0000
commit35c10e9ea8ad2770a857eded0a5d075ac739205d (patch)
treeb4f31c94bec43aad07f6be7a31024fce7f946ed9 /databases/postgis/Makefile
parente6cc6d53d29848731f7069d9218b4e2d07a425df (diff)
Update to 1.0.6.
The 1.0.6 release includes many small bug fixes and initial support for PostgreSQL 8.2. PR: ports/90169 Submitted by: Anderson S. Ferreira <anderson@cnpm.embrapa.br>
Notes
Notes: svn path=/head/; revision=151049
Diffstat (limited to 'databases/postgis/Makefile')
-rw-r--r--databases/postgis/Makefile35
1 files changed, 19 insertions, 16 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 9b70eb361b2a..99b8f85ca76f 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -6,20 +6,22 @@
#
PORTNAME= postgis
-DISTVERSION= 1.0.5
+DISTVERSION= 1.0.6
CATEGORIES= databases
MASTER_SITES= http://postgis.refractions.net/download/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Adds support for geographic objects to PostgreSQL databases
+BUILD_DEPENDS= ${NONEXISTENT}:${PGSQL_PORTDIR}:configure
LIB_DEPENDS= proj.5:${PORTSDIR}/graphics/proj
+USE_PGSQL= yes
USE_GMAKE= yes
USE_BISON= yes
USE_PERL5_BUILD= yes
-PGSQL_SRC= ${WRKDIR}/pgsql/postgresql
+MAN1= pgsql2shp.1 shp2pgsql.1
INSTALL_TARGET= install
INSTALLS_SHLIB= no
@@ -27,10 +29,6 @@ INSTALLS_SHLIB= no
OPTIONS= GEOS "Include GEOS - the OpenGIS 'Simple Features for SQL'" off \
UTF8 "UTF-8 support for shp2pgsql. (needs libiconv)" off
-USE_PGSQL= YES
-
-.include <bsd.port.pre.mk>
-
MAKE_ARGS= PGSQL_SRC="${PGSQL_SRC}" \
USE_PROJ=1 \
DATADIR="${PREFIX}/share/postgis" \
@@ -38,9 +36,20 @@ MAKE_ARGS= PGSQL_SRC="${PGSQL_SRC}" \
BINDIR="${PREFIX}/bin" \
LIBDIR="${PREFIX}/lib"
-PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+.include <bsd.port.pre.mk>
-MAN1= pgsql2shp.1 shp2pgsql.1
+#Setting/finding PostgreSQL version we want.
+.if exists(${LOCALBASE}/bin/postmaster)
+PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | \
+ ${SED} -n 's/postmaster.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+.elif exists(${LOCALBASE}/bin/pg_config)
+PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+.else
+PGSQL_VER= ${DEFAULT_PGSQL_VER}
+.endif
+
+PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+PGSQL_SRC!= cd ${PGSQL_PORTDIR} && ${MAKE} -V WRKSRC
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
@@ -56,7 +65,7 @@ MAKE_ARGS+= USE_ICONV=1
.endif
.if defined(WITH_GEOS)
-LIB_DEPENDS+= geos.4:${PORTSDIR}/graphics/geos
+LIB_DEPENDS+= geos:${PORTSDIR}/graphics/geos
MAKE_ARGS+= USE_GEOS=1
.else
MAKE_ARGS+= USE_GEOS=0
@@ -65,14 +74,8 @@ MAKE_ARGS+= USE_GEOS=0
pre-everything::
@${SH} ${PKGINSTALL} ${PORTNAME} MESSAGE
-pre-configure:
- @([ -d ${WRKDIR}/pgsql ] || ${MKDIR} ${WRKDIR}/pgsql) && \
- cd ${PGSQL_PORTDIR} && \
- ${MAKE} WRKDIR=${WRKDIR}/pgsql configure && \
- ${MV} ${WRKDIR}/pgsql/postgresql* ${PGSQL_SRC} \
-
post-install:
- @([ -d ${PREFIX}/lib/postgresql ] || ${MKDIR} ${PREFIX}/lib/postgresql )
+ @ ${MKDIR} ${PREFIX}/lib/postgresql
@ ${LN} ${PREFIX}/lib/liblwgeom.so.1 ${PREFIX}/lib/postgresql
@ ${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL