aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-devel-server
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-12-04 12:00:49 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-12-04 12:00:49 +0000
commit8a928af72d1ebb839a332158c27129b8a154275e (patch)
treec658c0da17e05366791dbe372c9e966663a70265 /databases/postgresql-devel-server
parent75d6fb12df9343cebb166dc9ac575ae77c24dd4d (diff)
downloadports-8a928af72d1ebb839a332158c27129b8a154275e.tar.gz
ports-8a928af72d1ebb839a332158c27129b8a154275e.zip
Notes
Diffstat (limited to 'databases/postgresql-devel-server')
-rw-r--r--databases/postgresql-devel-server/Makefile29
-rw-r--r--databases/postgresql-devel-server/distinfo8
-rw-r--r--databases/postgresql-devel-server/files/pgsql.sh.tmpl20
-rw-r--r--databases/postgresql-devel-server/files/pkg-message.server4
-rw-r--r--databases/postgresql-devel-server/pkg-install2
-rw-r--r--databases/postgresql-devel-server/pkg-plist134
6 files changed, 138 insertions, 59 deletions
diff --git a/databases/postgresql-devel-server/Makefile b/databases/postgresql-devel-server/Makefile
index 05f6cc59e9c2..69ab124d5654 100644
--- a/databases/postgresql-devel-server/Makefile
+++ b/databases/postgresql-devel-server/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
#
-PORTNAME?= postgresql
-PORTVERSION?= 7.3.4
-PORTREVISION= 1
+PORTNAME= postgresql
+PORTVERSION?= 7.4
+PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${PORTVERSION}
@@ -20,6 +20,7 @@ COMMENT?= The most advanced open-source database available anywhere
WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
+USE_BZIP2= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -36,6 +37,10 @@ CONFIGURE_ARGS= --with-libraries=${LOCALBASE}/lib \
--with-includes=${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+.if defined(WITH_PAM)
+CONFIGURE_ARGS+= --with-pam
+.endif
+
.if !defined(WITHOUT_GNUGETOPT)
USE_GETOPT_LONG=yes
.endif
@@ -50,7 +55,7 @@ PLIST_SUB+= GETTEXT="@comment "
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -funroll-loops
+CFLAGS+= -O3 -funroll-loops
.endif
.if defined(WITH_DEBUG)
@@ -62,18 +67,20 @@ INSTALL_TARGET= install-strip
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
-CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
+CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
.endif
.if defined(WITHOUT_SERVER)
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
+CONFLICTS= postgresql-7*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
+CONFLICTS= postgresql-7*client
PLIST_SUB+= SERVER=""
-INSTALL_TARGET+= install-all-headers
+INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
.endif
@@ -92,7 +99,7 @@ WITH_KRB5= yes
.if defined(WITH_KRB5)
CONFIGURE_ARGS+= --with-krb5="`${KRB5CONF} --prefix krb5`"
LDFLAGS+= `${KRB5CONF} --libs krb5`
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
.endif
.if defined(WITH_TESTS)
@@ -110,7 +117,10 @@ MAN1= clusterdb.1 createdb.1 createlang.1 createuser.1 dropdb.1 \
pg_resetxlog.1 pg_restore.1 pgtclsh.1 pgtksh.1 postgres.1 \
postmaster.1 psql.1 vacuumdb.1
-MAN7= abort.7 alter_database.7 alter_group.7 alter_table.7 \
+MAN7= abort.7 alter_aggregate.7 alter_conversion.7 \
+ alter_database.7 alter_domain.7 alter_function.7 \
+ alter_group.7 alter_language.7 alter_operator_class.7 \
+ alter_schema.7 alter_sequence.7 alter_table.7 \
alter_trigger.7 alter_user.7 analyze.7 begin.7 checkpoint.7 \
close.7 cluster.7 comment.7 commit.7 copy.7 create_aggregate.7 \
create_cast.7 create_constraint_trigger.7 create_conversion.7 \
@@ -142,9 +152,10 @@ pre-everything::
@${ECHO} " WITHOUT_GETTEXT Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
- @${ECHO} " only install binaries, headers and libs"
+ @${ECHO} " only install binaries, headers and libs"
@${ECHO} " for PostgreSQL clients"
@${ECHO} " WITHOUT_SSL Builds without OpenSSL support"
+ @${ECHO} " WITH_PAM Builds with PAM support"
@${ECHO} " WITH_MIT_KRB5 Builds with MIT's kerberos support"
@${ECHO} " WITH_HEIMDAL_KRB5 Builds with Heimdal's kerberos support"
@${ECHO} " WITH_OPTIMIZED_CFLAGS Builds with compiler optimizations (-O3)"
diff --git a/databases/postgresql-devel-server/distinfo b/databases/postgresql-devel-server/distinfo
index f97651c7ef11..f36c65ae2d5e 100644
--- a/databases/postgresql-devel-server/distinfo
+++ b/databases/postgresql-devel-server/distinfo
@@ -1,4 +1,4 @@
-MD5 (postgresql/postgresql-base-7.3.4.tar.gz) = 2b8600cc0f0c2d80271b533c394c886b
-MD5 (postgresql/postgresql-opt-7.3.4.tar.gz) = 3a0f0254bf9d6dccc61baa149c68ae75
-MD5 (postgresql/postgresql-docs-7.3.4.tar.gz) = 0144134674614e6b6a54103482f8acb2
-MD5 (postgresql/postgresql-test-7.3.4.tar.gz) = 7734ec70bb8e3d3bb3ba49e6dcee10e5
+MD5 (postgresql/postgresql-base-7.4.tar.bz2) = a1af58384f506ed63c1d960ab43a2b3b
+MD5 (postgresql/postgresql-opt-7.4.tar.bz2) = df425a08172b1e6ca41e7720b65a6b15
+MD5 (postgresql/postgresql-test-7.4.tar.bz2) = 3c104928f6dadb8fa6086b5ae8060835
+MD5 (postgresql/postgresql-docs-7.4.tar.bz2) = b8f1d43dc64b6813b3239f36425c8cb8
diff --git a/databases/postgresql-devel-server/files/pgsql.sh.tmpl b/databases/postgresql-devel-server/files/pgsql.sh.tmpl
index 0d85d6fba25d..3f8706d6af0c 100644
--- a/databases/postgresql-devel-server/files/pgsql.sh.tmpl
+++ b/databases/postgresql-devel-server/files/pgsql.sh.tmpl
@@ -9,30 +9,32 @@
PREFIX=%%PREFIX%%
PGBIN=${PREFIX}/bin
-logfile=/var/log/pgsql
case $1 in
start)
- touch ${logfile}
- chmod 600 ${logfile}
- chown pgsql:pgsql ${logfile}
[ -x ${PGBIN}/pg_ctl ] && {
- su -l pgsql -c \
- "[ -d \${PGDATA} ] && exec ${PREFIX}/bin/pg_ctl start -s -w -l ${logfile}"
echo -n ' pgsql'
+ su -l pgsql -c \
+ "[ -d \${PGDATA} ] && exec ${PREFIX}/bin/pg_ctl start -s -w"
}
;;
stop)
[ -x ${PGBIN}/pg_ctl ] && {
- su -l pgsql -c "exec ${PREFIX}/bin/pg_ctl stop -s -m fast"
echo -n ' pgsql'
+ su -l pgsql -c "exec ${PREFIX}/bin/pg_ctl stop -s -m fast"
}
;;
restart)
[ -x ${PGBIN}/pg_ctl ] && {
- exec su -l pgsql -c "exec ${PREFIX}/bin/pg_ctl restart -s -m fast -l ${logfile}"
+ exec su -l pgsql -c "exec ${PREFIX}/bin/pg_ctl restart -s -m fast"
+ }
+ ;;
+
+reload)
+ [ -x ${PGBIN}/pg_ctl ] && {
+ exec su -l pgsql -c "exec ${PREFIX}/bin/pg_ctl reload"
}
;;
@@ -43,7 +45,7 @@ status)
;;
*)
- echo "usage: `basename $0` {start|stop|restart|status}" >&2
+ echo "usage: `basename $0` {start|stop|restart|reload|status}" >&2
exit 64
;;
esac
diff --git a/databases/postgresql-devel-server/files/pkg-message.server b/databases/postgresql-devel-server/files/pkg-message.server
index 6027012da44c..a2e7293462ca 100644
--- a/databases/postgresql-devel-server/files/pkg-message.server
+++ b/databases/postgresql-devel-server/files/pkg-message.server
@@ -13,5 +13,9 @@ You can then start PostgreSQL by running:
/usr/local/etc/rc.d/010.pgsql.sh start
For postmaster settings, see ~pgsql/data/postgresql.conf
+
+NB. FreeBSD's PostgreSQL port now by default logs to syslog
+ See ~pgsql/data/postgresql.conf for more info
+
For more tips, read ~pgsql/post-install-notes
======================================================================
diff --git a/databases/postgresql-devel-server/pkg-install b/databases/postgresql-devel-server/pkg-install
index a4bde386e5c5..5c7141155fb5 100644
--- a/databases/postgresql-devel-server/pkg-install
+++ b/databases/postgresql-devel-server/pkg-install
@@ -11,7 +11,7 @@ backupwarning() {
=========== BACKUP YOUR DATA! =============
As always, backup your data before
upgrading. If the upgrade leads to a higher
- minor revision (e.g. 7.2.x -> 7.3), a dump
+ minor revision (e.g. 7.3.x -> 7.4), a dump
and restore of all databases is
required. This is *NOT* done by the port!
diff --git a/databases/postgresql-devel-server/pkg-plist b/databases/postgresql-devel-server/pkg-plist
index effd8e4f2f71..6c4ba1c3568b 100644
--- a/databases/postgresql-devel-server/pkg-plist
+++ b/databases/postgresql-devel-server/pkg-plist
@@ -33,21 +33,38 @@ include/postgresql/internal/libpq-int.h
include/postgresql/internal/postgres_fe.h
include/postgresql/internal/pqexpbuffer.h
@dirrm include/postgresql/internal
+include/compatlib.h
+include/datetime.h
+include/decimal.h
+include/ecpg_informix.h
include/ecpgerrno.h
include/ecpglib.h
include/ecpgtype.h
include/libpq-fe.h
include/pg_config.h
include/pg_config_os.h
+include/pgtypes_date.h
+include/pgtypes_error.h
+include/pgtypes_interval.h
+include/pgtypes_numeric.h
+include/pgtypes_timestamp.h
include/postgres_ext.h
include/sql3types.h
include/sqlca.h
+include/sqlda.h
+include/sqltypes.h
lib/libecpg.a
lib/libecpg.so
-lib/libecpg.so.3
+lib/libecpg.so.4
+lib/libecpg_compat.a
+lib/libecpg_compat.so
+lib/libecpg_compat.so.1
lib/libpq.a
lib/libpq.so
lib/libpq.so.3
+lib/libpgtypes.a
+lib/libpgtypes.so
+lib/libpgtypes.so.1
%%SERVER%%lib/postgresql/ascii_and_mic.so
%%SERVER%%lib/postgresql/cyrillic_and_mic.so
%%SERVER%%lib/postgresql/euc_cn_and_mic.so
@@ -77,57 +94,93 @@ lib/libpq.so.3
%%SERVER%%lib/postgresql/plpgsql.so
@unexec rmdir %D/lib/postgresql 2>/dev/null || true
%%SERVER%%share/postgresql/502.pgsql
-%%SERVER%%share/postgresql/postgres.bki
-%%SERVER%%share/postgresql/postgres.description
+%%SERVER%%share/postgresql/conversion_create.sql
+%%SERVER%%share/postgresql/information_schema.sql
%%SERVER%%share/postgresql/pg_hba.conf.sample
%%SERVER%%share/postgresql/pg_ident.conf.sample
+%%SERVER%%share/postgresql/pg_service.conf.sample
+%%SERVER%%share/postgresql/postgres.bki
+%%SERVER%%share/postgresql/postgres.description
%%SERVER%%share/postgresql/postgresql.conf.sample
-%%SERVER%%share/postgresql/conversion_create.sql
+%%SERVER%%share/postgresql/sql_features.txt
share/postgresql/post-install-notes
@unexec rmdir %D/share/postgresql 2>/dev/null || true
+%%GETTEXT%%share/locale/cs/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/cs/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/cs/LC_MESSAGES/pg_dump.mo
+%%GETTEXT%%share/locale/cs/LC_MESSAGES/pg_resetxlog.mo
+%%GETTEXT%%share/locale/cs/LC_MESSAGES/pgscripts.mo
%%GETTEXT%%share/locale/cs/LC_MESSAGES/psql.mo
-%%GETTEXT%%share/locale/cs/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/de/LC_MESSAGES/pg_dump.mo
%%GETTEXT%%share/locale/de/LC_MESSAGES/psql.mo
%%GETTEXT%%share/locale/de/LC_MESSAGES/pg_controldata.mo
%%GETTEXT%%share/locale/de/LC_MESSAGES/pg_resetxlog.mo
%%GETTEXT%%share/locale/de/LC_MESSAGES/libpq.mo
-%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_dump.mo
+%%GETTEXT%%share/locale/de/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/es/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/es/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/es/LC_MESSAGES/pg_dump.mo
+%%GETTEXT%%share/locale/es/LC_MESSAGES/pg_resetxlog.mo
+%%GETTEXT%%share/locale/es/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/es/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/fr/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/fr/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/fr/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/hr/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/hu/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/hu/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/hu/LC_MESSAGES/pg_resetxlog.mo
+%%GETTEXT%%share/locale/it/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/it/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/it/LC_MESSAGES/pg_dump.mo
+%%GETTEXT%%share/locale/it/LC_MESSAGES/pg_resetxlog.mo
+%%GETTEXT%%share/locale/it/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/it/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/nb/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/nb/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/nb/LC_MESSAGES/pg_dump.mo
+%%GETTEXT%%share/locale/nb/LC_MESSAGES/pg_resetxlog.mo
+%%GETTEXT%%share/locale/nb/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_dump.mo
%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pg_resetxlog.mo
-%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/libpq.mo
-%%GETTEXT%%share/locale/ru/LC_MESSAGES/pg_dump.mo
-%%GETTEXT%%share/locale/ru/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/ru/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/ru/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/ru/LC_MESSAGES/pg_dump.mo
%%GETTEXT%%share/locale/ru/LC_MESSAGES/pg_resetxlog.mo
-%%GETTEXT%%share/locale/ru/LC_MESSAGES/libpq.mo
-%%GETTEXT%%share/locale/sv/LC_MESSAGES/pg_dump.mo
-%%GETTEXT%%share/locale/sv/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/ru/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/ru/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/sl/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/sl/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/sl/LC_MESSAGES/pg_resetxlog.mo
+%%GETTEXT%%share/locale/sl/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/sl/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/sv/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/sv/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/sv/LC_MESSAGES/pg_dump.mo
%%GETTEXT%%share/locale/sv/LC_MESSAGES/pg_resetxlog.mo
-%%GETTEXT%%share/locale/sv/LC_MESSAGES/libpq.mo
-%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_dump.mo
-%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/sv/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/sv/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_controldata.mo
+%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_dump.mo
%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pg_resetxlog.mo
-%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/libpq.mo
+%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/pgscripts.mo
+%%GETTEXT%%share/locale/zh_CN/LC_MESSAGES/psql.mo
+%%GETTEXT%%share/locale/zh_TW/LC_MESSAGES/libpq.mo
%%GETTEXT%%share/locale/zh_TW/LC_MESSAGES/pg_dump.mo
%%GETTEXT%%share/locale/zh_TW/LC_MESSAGES/psql.mo
-%%GETTEXT%%share/locale/zh_TW/LC_MESSAGES/libpq.mo
-%%GETTEXT%%share/locale/fr/LC_MESSAGES/psql.mo
-%%GETTEXT%%share/locale/fr/LC_MESSAGES/pg_controldata.mo
-%%GETTEXT%%share/locale/fr/LC_MESSAGES/libpq.mo
-%%GETTEXT%%share/locale/hu/LC_MESSAGES/psql.mo
-%%GETTEXT%%share/locale/hu/LC_MESSAGES/pg_controldata.mo
-%%GETTEXT%%share/locale/hu/LC_MESSAGES/pg_resetxlog.mo
-%%GETTEXT%%share/locale/es/LC_MESSAGES/pg_controldata.mo
-%%GETTEXT%%share/locale/es/LC_MESSAGES/libpq.mo
%%SERVER%%%%GETTEXT%%share/locale/cs/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/de/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/es/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/hr/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/hu/LC_MESSAGES/postgres.mo
+%%SERVER%%%%GETTEXT%%share/locale/it/LC_MESSAGES/postgres.mo
+%%SERVER%%%%GETTEXT%%share/locale/nb/LC_MESSAGES/postgres.mo
+%%SERVER%%%%GETTEXT%%share/locale/pt_BR/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/ru/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/sv/LC_MESSAGES/postgres.mo
%%SERVER%%%%GETTEXT%%share/locale/tr/LC_MESSAGES/postgres.mo
@@ -173,6 +226,7 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/access/rtscan.h
%%SERVER%%include/postgresql/server/access/sdir.h
%%SERVER%%include/postgresql/server/access/skey.h
+%%SERVER%%include/postgresql/server/access/slru.h
%%SERVER%%include/postgresql/server/access/strat.h
%%SERVER%%include/postgresql/server/access/transam.h
%%SERVER%%include/postgresql/server/access/tupdesc.h
@@ -222,6 +276,7 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/catalog/pg_trigger.h
%%SERVER%%include/postgresql/server/catalog/pg_type.h
%%SERVER%%include/postgresql/server/catalog/pg_version.h
+%%SERVER%%include/postgresql/server/commands/alter.h
%%SERVER%%include/postgresql/server/commands/async.h
%%SERVER%%include/postgresql/server/commands/cluster.h
%%SERVER%%include/postgresql/server/commands/comment.h
@@ -238,6 +293,7 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/commands/sequence.h
%%SERVER%%include/postgresql/server/commands/tablecmds.h
%%SERVER%%include/postgresql/server/commands/trigger.h
+%%SERVER%%include/postgresql/server/commands/typecmds.h
%%SERVER%%include/postgresql/server/commands/user.h
%%SERVER%%include/postgresql/server/commands/vacuum.h
%%SERVER%%include/postgresql/server/commands/variable.h
@@ -271,6 +327,7 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/executor/nodeUnique.h
%%SERVER%%include/postgresql/server/executor/spi.h
%%SERVER%%include/postgresql/server/executor/spi_priv.h
+%%SERVER%%include/postgresql/server/executor/tstoreReceiver.h
%%SERVER%%include/postgresql/server/executor/tuptable.h
%%SERVER%%include/postgresql/server/lib/dllist.h
%%SERVER%%include/postgresql/server/lib/lispsort.h
@@ -279,14 +336,15 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/libpq/be-fsstubs.h
%%SERVER%%include/postgresql/server/libpq/crypt.h
%%SERVER%%include/postgresql/server/libpq/hba.h
+%%SERVER%%include/postgresql/server/libpq/ip.h
%%SERVER%%include/postgresql/server/libpq/libpq-be.h
%%SERVER%%include/postgresql/server/libpq/libpq-fs.h
%%SERVER%%include/postgresql/server/libpq/libpq.h
-%%SERVER%%include/postgresql/server/libpq/password.h
%%SERVER%%include/postgresql/server/libpq/pqcomm.h
%%SERVER%%include/postgresql/server/libpq/pqformat.h
%%SERVER%%include/postgresql/server/libpq/pqsignal.h
%%SERVER%%include/postgresql/server/mb/pg_wchar.h
+%%SERVER%%include/postgresql/server/nodes/bitmapset.h
%%SERVER%%include/postgresql/server/nodes/execnodes.h
%%SERVER%%include/postgresql/server/nodes/makefuncs.h
%%SERVER%%include/postgresql/server/nodes/memnodes.h
@@ -342,6 +400,7 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/port/aix.h
%%SERVER%%include/postgresql/server/port/beos.h
%%SERVER%%include/postgresql/server/port/bsdi.h
+%%SERVER%%include/postgresql/server/port/cygwin.h
%%SERVER%%include/postgresql/server/port/darwin.h
%%SERVER%%include/postgresql/server/port/dgux.h
%%SERVER%%include/postgresql/server/port/freebsd.h
@@ -360,13 +419,11 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/port/ultrix4.h
%%SERVER%%include/postgresql/server/port/univel.h
%%SERVER%%include/postgresql/server/port/unixware.h
-%%SERVER%%include/postgresql/server/port/win.h
%%SERVER%%include/postgresql/server/port/win32.h
-%%SERVER%%include/postgresql/server/regex/cclass.h
-%%SERVER%%include/postgresql/server/regex/cname.h
+%%SERVER%%include/postgresql/server/regex/regcustom.h
+%%SERVER%%include/postgresql/server/regex/regerrs.h
%%SERVER%%include/postgresql/server/regex/regex.h
-%%SERVER%%include/postgresql/server/regex/regex2.h
-%%SERVER%%include/postgresql/server/regex/utils.h
+%%SERVER%%include/postgresql/server/regex/regguts.h
%%SERVER%%include/postgresql/server/rewrite/prs2lock.h
%%SERVER%%include/postgresql/server/rewrite/rewriteDefine.h
%%SERVER%%include/postgresql/server/rewrite/rewriteHandler.h
@@ -392,7 +449,6 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/storage/lock.h
%%SERVER%%include/postgresql/server/storage/lwlock.h
%%SERVER%%include/postgresql/server/storage/off.h
-%%SERVER%%include/postgresql/server/storage/page.h
%%SERVER%%include/postgresql/server/storage/pg_sema.h
%%SERVER%%include/postgresql/server/storage/pg_shmem.h
%%SERVER%%include/postgresql/server/storage/pmsignal.h
@@ -414,7 +470,6 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/utils/acl.h
%%SERVER%%include/postgresql/server/utils/array.h
%%SERVER%%include/postgresql/server/utils/ascii.h
-%%SERVER%%include/postgresql/server/utils/bit.h
%%SERVER%%include/postgresql/server/utils/builtins.h
%%SERVER%%include/postgresql/server/utils/cash.h
%%SERVER%%include/postgresql/server/utils/catcache.h
@@ -424,13 +479,15 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/utils/dynahash.h
%%SERVER%%include/postgresql/server/utils/dynamic_loader.h
%%SERVER%%include/postgresql/server/utils/elog.h
-%%SERVER%%include/postgresql/server/utils/fcache.h
+%%SERVER%%include/postgresql/server/utils/errcodes.h
%%SERVER%%include/postgresql/server/utils/fmgroids.h
%%SERVER%%include/postgresql/server/utils/fmgrtab.h
%%SERVER%%include/postgresql/server/utils/formatting.h
%%SERVER%%include/postgresql/server/utils/geo_decls.h
%%SERVER%%include/postgresql/server/utils/guc.h
+%%SERVER%%include/postgresql/server/utils/guc_tables.h
%%SERVER%%include/postgresql/server/utils/hsearch.h
+%%SERVER%%include/postgresql/server/utils/help_config.h
%%SERVER%%include/postgresql/server/utils/inet.h
%%SERVER%%include/postgresql/server/utils/int8.h
%%SERVER%%include/postgresql/server/utils/inval.h
@@ -454,15 +511,20 @@ share/postgresql/post-install-notes
%%SERVER%%include/postgresql/server/utils/tqual.h
%%SERVER%%include/postgresql/server/utils/tuplesort.h
%%SERVER%%include/postgresql/server/utils/tuplestore.h
+%%SERVER%%include/postgresql/server/utils/typcache.h
%%SERVER%%include/postgresql/server/utils/varbit.h
-%%SERVER%%include/postgresql/server/pg_config.h
-%%SERVER%%include/postgresql/server/pg_config_os.h
%%SERVER%%include/postgresql/server/c.h
%%SERVER%%include/postgresql/server/dynloader.h
%%SERVER%%include/postgresql/server/fmgr.h
%%SERVER%%include/postgresql/server/funcapi.h
+%%SERVER%%include/postgresql/server/getaddrinfo.h
+%%SERVER%%include/postgresql/server/getopt_long.h
%%SERVER%%include/postgresql/server/miscadmin.h
+%%SERVER%%include/postgresql/server/pg_config.h
+%%SERVER%%include/postgresql/server/pg_config_manual.h
+%%SERVER%%include/postgresql/server/pg_config_os.h
%%SERVER%%include/postgresql/server/pgstat.h
+%%SERVER%%include/postgresql/server/port.h
%%SERVER%%include/postgresql/server/postgres.h
%%SERVER%%include/postgresql/server/postgres_ext.h
%%SERVER%%include/postgresql/server/postgres_fe.h