aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpgeasy/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-07-21 22:51:49 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-07-21 22:51:49 +0000
commit67a16737d6e5b822f01a49c215c8a39fb5619cb8 (patch)
tree6c961f239627fa97f1fe13f7d8df12b6f9ba3319 /databases/postgresql-libpgeasy/Makefile
parentb4a4d2220f7e8dfd167d32c21f19c0fc34edb1b9 (diff)
downloadports-67a16737d6e5b822f01a49c215c8a39fb5619cb8.tar.gz
ports-67a16737d6e5b822f01a49c215c8a39fb5619cb8.zip
Notes
Diffstat (limited to 'databases/postgresql-libpgeasy/Makefile')
-rw-r--r--databases/postgresql-libpgeasy/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/databases/postgresql-libpgeasy/Makefile b/databases/postgresql-libpgeasy/Makefile
new file mode 100644
index 000000000000..e65832882815
--- /dev/null
+++ b/databases/postgresql-libpgeasy/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: PostgreSQL library pgeasy
+# Date created: October 24st, 2004
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PKGNAMEPREFIX= postgresql-
+PORTNAME= libpgeasy
+PORTVERSION= 3.0.4
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_PGSQL}
+MASTER_SITE_SUBDIR= projects/gborg/pgeasy/stable
+DIST_SUBDIR= postgresql
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= An easy-to-use C interface to PostgreSQL
+
+USE_PGSQL= YES
+USE_GMAKE= YES
+INSTALLS_SHLIB= YES
+GNU_CONFIGURE= YES
+DOCSDIR= ${PREFIX}/share/doc/postgresql/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/postgresql/${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @- ${MKDIR} -m 755 ${EXAMPLESDIR} ;\
+ ${INSTALL} ${WRKSRC}/examples/* ${EXAMPLESDIR} ;\
+ ${MKDIR} -m 755 ${DOCSDIR} ;\
+ ${INSTALL} ${WRKSRC}/docs/libpgeasy.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
+