aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx3
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-07-03 13:21:36 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-07-03 13:21:36 +0000
commita5bd3e8755db68736e9c1ee232d2ff61d67c9d0c (patch)
tree181ef8b6de65ef9b1bc83c9b00d653e41c0df4a9 /databases/postgresql-libpqxx3
parentc4c1e30d35dd14b00468531d5656ed1e97cfec02 (diff)
downloadports-a5bd3e8755db68736e9c1ee232d2ff61d67c9d0c.tar.gz
ports-a5bd3e8755db68736e9c1ee232d2ff61d67c9d0c.zip
Notes
Diffstat (limited to 'databases/postgresql-libpqxx3')
-rw-r--r--databases/postgresql-libpqxx3/Makefile15
-rw-r--r--databases/postgresql-libpqxx3/distinfo4
-rw-r--r--databases/postgresql-libpqxx3/files/patch-Makefile.in6
-rw-r--r--databases/postgresql-libpqxx3/files/patch-libpqxx.spec.in12
-rw-r--r--databases/postgresql-libpqxx3/files/patch-svn_166522
-rw-r--r--databases/postgresql-libpqxx3/pkg-plist29
6 files changed, 64 insertions, 24 deletions
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
index 1d3387cd20e7..b98ef72f764a 100644
--- a/databases/postgresql-libpqxx3/Makefile
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -6,24 +6,27 @@
#
PORTNAME= libpqxx
-PORTVERSION= 3.0.2
+PORTVERSION= 3.1
CATEGORIES= databases
-MASTER_SITES= http://pqxx.org/download/software/libpqxx/
+MASTER_SITES= http://pqxx.org/download/software/${PORTNAME}/
PKGNAMEPREFIX= postgresql-
DIST_SUBDIR= postgresql
MAINTAINER= 20080111.freebsd.org@ab.ote.we.lv
-COMMENT= A new C++ interface for PostgreSQL
+COMMENT= New C++ interface for PostgreSQL
CONFLICTS= postgresql-libpqxx-[2-4].*
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}30
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}3
+PORTSCOUT= limit:^2\.
USE_PGSQL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-PLIST_SUB= SHLIBVERSION=3.0
+PLIST_SUB= PORTVERSION=${PORTVERSION}
-CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
+ --enable-shared \
+ --with-postgres-include=${LOCALBASE}/include/postgresql
.include <bsd.port.mk>
diff --git a/databases/postgresql-libpqxx3/distinfo b/databases/postgresql-libpqxx3/distinfo
index def7a1baf8fa..2246a393bde7 100644
--- a/databases/postgresql-libpqxx3/distinfo
+++ b/databases/postgresql-libpqxx3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postgresql/libpqxx-3.0.2.tar.gz) = de265ab5d397ace7596c3b6d19a0057ce2ba58477315acf9165b0a97facab6ca
-SIZE (postgresql/libpqxx-3.0.2.tar.gz) = 1565644
+SHA256 (postgresql/libpqxx-3.1.tar.gz) = 8950433f193e118cfd36ab91391eb174ef48897bacc26197da596988e66796a0
+SIZE (postgresql/libpqxx-3.1.tar.gz) = 1771846
diff --git a/databases/postgresql-libpqxx3/files/patch-Makefile.in b/databases/postgresql-libpqxx3/files/patch-Makefile.in
index 414342128af2..3d2b02a8ec93 100644
--- a/databases/postgresql-libpqxx3/files/patch-Makefile.in
+++ b/databases/postgresql-libpqxx3/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in 2009-08-14 10:16:35.000000000 -0700
-+++ Makefile.in.new 2010-01-13 23:09:39.000000000 -0800
-@@ -226,7 +226,7 @@
+--- Makefile.in.orig 2011-09-12 11:39:56.000000000 +0200
++++ Makefile.in 2011-09-12 11:40:48.000000000 +0200
+@@ -270,7 +270,7 @@
MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.log configure \
stamp-h.in
diff --git a/databases/postgresql-libpqxx3/files/patch-libpqxx.spec.in b/databases/postgresql-libpqxx3/files/patch-libpqxx.spec.in
deleted file mode 100644
index 3e9e115743bb..000000000000
--- a/databases/postgresql-libpqxx3/files/patch-libpqxx.spec.in
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN libpqxx-3.0.2.dist/libpqxx.spec.in libpqxx-3.0.2/libpqxx.spec.in
---- libpqxx.spec.in 2009-07-03 22:38:38.000000000 -0700
-+++ libpqxx.spec.in.new 2010-01-13 21:24:41.000000000 -0800
-@@ -58,7 +58,7 @@
- %files devel
- %defattr(-, root, root)
- %{_libdir}/*a
--%{_libdir}/pkgconfig/libpqxx.pc
-+%{_prefix}/libdata/pkgconfig/libpqxx.pc
- %{_includedir}/*
- %{_bindir}/pqxx-config
-
diff --git a/databases/postgresql-libpqxx3/files/patch-svn_1665 b/databases/postgresql-libpqxx3/files/patch-svn_1665
new file mode 100644
index 000000000000..eb1ffab8dc12
--- /dev/null
+++ b/databases/postgresql-libpqxx3/files/patch-svn_1665
@@ -0,0 +1,22 @@
+Index: /trunk/include/pqxx/util.hxx
+===================================================================
+--- ./include/pqxx/util.hxx (revision 1638)
++++ ./include/pqxx/util.hxx (revision 1665)
+@@ -33,4 +33,6 @@
+ #include <memory>
+ #endif
++
++#include "pqxx/strconv"
+
+
+Index: /trunk/include/pqxx/cursor.hxx
+===================================================================
+--- ./include/pqxx/cursor.hxx (revision 1559)
++++ ./include/pqxx/cursor.hxx (revision 1665)
+@@ -308,5 +308,5 @@
+ transaction_base &trans,
+ const PGSTD::string adopted_cursor) :
+- m_cur(trans, adopted_cursor, up, op)
++ m_cur(trans, adopted_cursor, op)
+ {
+ // Put cursor in known position
diff --git a/databases/postgresql-libpqxx3/pkg-plist b/databases/postgresql-libpqxx3/pkg-plist
index 9d4d8b5c4cd1..13a6e83d4e0b 100644
--- a/databases/postgresql-libpqxx3/pkg-plist
+++ b/databases/postgresql-libpqxx3/pkg-plist
@@ -19,6 +19,27 @@ include/pqxx/dbtransaction
include/pqxx/dbtransaction.hxx
include/pqxx/except
include/pqxx/except.hxx
+include/pqxx/internal/callgate.hxx
+include/pqxx/internal/gates/connection-dbtransaction.hxx
+include/pqxx/internal/gates/connection-largeobject.hxx
+include/pqxx/internal/gates/connection-notify-listener.hxx
+include/pqxx/internal/gates/connection-parameterized_invocation.hxx
+include/pqxx/internal/gates/connection-pipeline.hxx
+include/pqxx/internal/gates/connection-prepare-declaration.hxx
+include/pqxx/internal/gates/connection-prepare-invocation.hxx
+include/pqxx/internal/gates/connection-reactivation_avoidance_exemption.hxx
+include/pqxx/internal/gates/connection-sql_cursor.hxx
+include/pqxx/internal/gates/connection-transaction.hxx
+include/pqxx/internal/gates/icursor_iterator-icursorstream.hxx
+include/pqxx/internal/gates/icursorstream-icursor_iterator.hxx
+include/pqxx/internal/gates/result-connection.hxx
+include/pqxx/internal/gates/result-creation.hxx
+include/pqxx/internal/gates/result-sql_cursor.hxx
+include/pqxx/internal/gates/transaction-subtransaction.hxx
+include/pqxx/internal/gates/transaction-tablereader.hxx
+include/pqxx/internal/gates/transaction-tablewriter.hxx
+include/pqxx/internal/gates/transaction-transactionfocus.hxx
+include/pqxx/internal/statement_parameters.hxx
include/pqxx/isolation
include/pqxx/isolation.hxx
include/pqxx/largeobject
@@ -28,6 +49,7 @@ include/pqxx/nontransaction
include/pqxx/nontransaction.hxx
include/pqxx/notify-listen
include/pqxx/notify-listen.hxx
+include/pqxx/performance.hxx
include/pqxx/pipeline
include/pqxx/pipeline.hxx
include/pqxx/pqxx
@@ -37,6 +59,8 @@ include/pqxx/result
include/pqxx/result.hxx
include/pqxx/robusttransaction
include/pqxx/robusttransaction.hxx
+include/pqxx/strconv
+include/pqxx/strconv.hxx
include/pqxx/subtransaction
include/pqxx/subtransaction.hxx
include/pqxx/tablereader
@@ -55,10 +79,13 @@ include/pqxx/trigger
include/pqxx/trigger.hxx
include/pqxx/util
include/pqxx/util.hxx
+include/pqxx/version
include/pqxx/version.hxx
-lib/libpqxx-%%SHLIBVERSION%%.so
+lib/libpqxx-%%PORTVERSION%%.so
lib/libpqxx.a
lib/libpqxx.la
lib/libpqxx.so
libdata/pkgconfig/libpqxx.pc
+@dirrm include/pqxx/internal/gates
+@dirrm include/pqxx/internal
@dirrm include/pqxx