aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2011-09-12 09:49:57 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2011-09-12 09:49:57 +0000
commit03bf3b24da1171dde31852738518fc323266d482 (patch)
treec100af0aba718135b45f7ced25b5b307e7b63f0a /databases/postgresql-libpqxx
parentc00d89be09c76caa5c43415c190dadf9b18a4743 (diff)
downloadports-03bf3b24da1171dde31852738518fc323266d482.tar.gz
ports-03bf3b24da1171dde31852738518fc323266d482.zip
Notes
Diffstat (limited to 'databases/postgresql-libpqxx')
-rw-r--r--databases/postgresql-libpqxx/Makefile3
-rw-r--r--databases/postgresql-libpqxx/distinfo4
-rw-r--r--databases/postgresql-libpqxx/files/patch-Makefile.in10
-rw-r--r--databases/postgresql-libpqxx/pkg-plist32
4 files changed, 38 insertions, 11 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 2a473146a06d..4c44edbc2384 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libpqxx
-PORTVERSION= 2.6.9
-PORTREVISION= 2
+PORTVERSION= 3.1
CATEGORIES= databases
MASTER_SITES= http://pqxx.org/download/software/libpqxx/
PKGNAMEPREFIX= postgresql-
diff --git a/databases/postgresql-libpqxx/distinfo b/databases/postgresql-libpqxx/distinfo
index 7df407f8c582..2246a393bde7 100644
--- a/databases/postgresql-libpqxx/distinfo
+++ b/databases/postgresql-libpqxx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postgresql/libpqxx-2.6.9.tar.gz) = 2b2ef5dfb852667299e50727419075cf333bbbeffadaa398d96dc93bac6f7b6a
-SIZE (postgresql/libpqxx-2.6.9.tar.gz) = 1639557
+SHA256 (postgresql/libpqxx-3.1.tar.gz) = 8950433f193e118cfd36ab91391eb174ef48897bacc26197da596988e66796a0
+SIZE (postgresql/libpqxx-3.1.tar.gz) = 1771846
diff --git a/databases/postgresql-libpqxx/files/patch-Makefile.in b/databases/postgresql-libpqxx/files/patch-Makefile.in
index d1dd4d32ceef..3d2b02a8ec93 100644
--- a/databases/postgresql-libpqxx/files/patch-Makefile.in
+++ b/databases/postgresql-libpqxx/files/patch-Makefile.in
@@ -1,9 +1,9 @@
---- Makefile.in~ Sat May 27 12:46:50 2006
-+++ Makefile.in Sun May 28 17:51:23 2006
-@@ -212,7 +212,7 @@
+--- Makefile.in.orig 2011-09-12 11:39:56.000000000 +0200
++++ Makefile.in 2011-09-12 11:40:48.000000000 +0200
+@@ -270,7 +270,7 @@
+ MAINTAINERCLEANFILES = Makefile.in aclocal.m4 config.h.in config.log configure \
+ stamp-h.in
-
- #includedir=$(prefix)/include
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = libpqxx.pc
diff --git a/databases/postgresql-libpqxx/pkg-plist b/databases/postgresql-libpqxx/pkg-plist
index 9ae9e250a3eb..13a6e83d4e0b 100644
--- a/databases/postgresql-libpqxx/pkg-plist
+++ b/databases/postgresql-libpqxx/pkg-plist
@@ -3,7 +3,6 @@ include/pqxx/basic_connection
include/pqxx/basic_connection.hxx
include/pqxx/binarystring
include/pqxx/binarystring.hxx
-include/pqxx/cachedresult.h
include/pqxx/compiler-internal-post.hxx
include/pqxx/compiler-internal-pre.hxx
include/pqxx/compiler-public.hxx
@@ -15,12 +14,32 @@ include/pqxx/connection_base.hxx
include/pqxx/connectionpolicy
include/pqxx/connectionpolicy.hxx
include/pqxx/cursor
-include/pqxx/cursor.h
include/pqxx/cursor.hxx
include/pqxx/dbtransaction
include/pqxx/dbtransaction.hxx
include/pqxx/except
include/pqxx/except.hxx
+include/pqxx/internal/callgate.hxx
+include/pqxx/internal/gates/connection-dbtransaction.hxx
+include/pqxx/internal/gates/connection-largeobject.hxx
+include/pqxx/internal/gates/connection-notify-listener.hxx
+include/pqxx/internal/gates/connection-parameterized_invocation.hxx
+include/pqxx/internal/gates/connection-pipeline.hxx
+include/pqxx/internal/gates/connection-prepare-declaration.hxx
+include/pqxx/internal/gates/connection-prepare-invocation.hxx
+include/pqxx/internal/gates/connection-reactivation_avoidance_exemption.hxx
+include/pqxx/internal/gates/connection-sql_cursor.hxx
+include/pqxx/internal/gates/connection-transaction.hxx
+include/pqxx/internal/gates/icursor_iterator-icursorstream.hxx
+include/pqxx/internal/gates/icursorstream-icursor_iterator.hxx
+include/pqxx/internal/gates/result-connection.hxx
+include/pqxx/internal/gates/result-creation.hxx
+include/pqxx/internal/gates/result-sql_cursor.hxx
+include/pqxx/internal/gates/transaction-subtransaction.hxx
+include/pqxx/internal/gates/transaction-tablereader.hxx
+include/pqxx/internal/gates/transaction-tablewriter.hxx
+include/pqxx/internal/gates/transaction-transactionfocus.hxx
+include/pqxx/internal/statement_parameters.hxx
include/pqxx/isolation
include/pqxx/isolation.hxx
include/pqxx/largeobject
@@ -28,6 +47,9 @@ include/pqxx/largeobject.hxx
include/pqxx/libpq-forward.hxx
include/pqxx/nontransaction
include/pqxx/nontransaction.hxx
+include/pqxx/notify-listen
+include/pqxx/notify-listen.hxx
+include/pqxx/performance.hxx
include/pqxx/pipeline
include/pqxx/pipeline.hxx
include/pqxx/pqxx
@@ -37,6 +59,8 @@ include/pqxx/result
include/pqxx/result.hxx
include/pqxx/robusttransaction
include/pqxx/robusttransaction.hxx
+include/pqxx/strconv
+include/pqxx/strconv.hxx
include/pqxx/subtransaction
include/pqxx/subtransaction.hxx
include/pqxx/tablereader
@@ -55,9 +79,13 @@ include/pqxx/trigger
include/pqxx/trigger.hxx
include/pqxx/util
include/pqxx/util.hxx
+include/pqxx/version
+include/pqxx/version.hxx
lib/libpqxx-%%PORTVERSION%%.so
lib/libpqxx.a
lib/libpqxx.la
lib/libpqxx.so
libdata/pkgconfig/libpqxx.pc
+@dirrm include/pqxx/internal/gates
+@dirrm include/pqxx/internal
@dirrm include/pqxx