aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-odbc/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-09 18:51:19 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-09 18:51:19 +0000
commitc3dd807ed86d7900e165b0a7b4a820574f5d9943 (patch)
treef47fdabe17c9afbf1fcffff85339c01509a1963e /databases/postgresql-odbc/Makefile
parent65cc3f80d037fd2c2c7e3ed5390c098a0c95cbed (diff)
downloadports-c3dd807ed86d7900e165b0a7b4a820574f5d9943.tar.gz
ports-c3dd807ed86d7900e165b0a7b4a820574f5d9943.zip
Notes
Diffstat (limited to 'databases/postgresql-odbc/Makefile')
-rw-r--r--databases/postgresql-odbc/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/databases/postgresql-odbc/Makefile b/databases/postgresql-odbc/Makefile
index 0150fc3c565f..cf5b99650fec 100644
--- a/databases/postgresql-odbc/Makefile
+++ b/databases/postgresql-odbc/Makefile
@@ -19,23 +19,28 @@ MAINTAINER= girgen@FreeBSD.org
COMMENT= PostgreSQL ODBC client support
# PostgreSQL ODBC support needs an ODBC driver manager to be
-# installed, and it supports both iODBC and unixODBC. The following
-# variable may be set at built-time to either "iodbc" or "unixodbc",
-# with the former being the default:
-DRIVER_MANAGER?= iodbc
+# installed, and it supports both iODBC and unixODBC.
+
+.if defined(WITH_IODBC) && defined(WITH_UNIXODBC)
+IGNORE= selected mutually exclusive options: WITH_IODBC and WITH_UNIXODBC
+.endif
+
+.if !defined(WITH_IODBC) && !defined(WITH_UNIXODBC)
+WITH_IODBC?= yes
+.endif
# Note that there is a potential conflict between unixODBC's and
# postgres' libodbcpsql.so. unixODBC installs versions `1' & `2' of
# the named lib, while postgres installs version `0'. The postgres
# folks say their is the best, so you might be better off removing
# the others?
-.if ${DRIVER_MANAGER} == "unixodbc"
+.if defined(WITH_IODBC)
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+= --with-iodbc --with-odbcinst=${LOCALBASE}/etc/libiodbc
+.elif defined(WITH_UNIXODBC)
PKGNAMESUFFIX= -unixodbc
CONFIGURE_ARGS+= --with-unixodbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-.else # assume we're using iodbc
-LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
-CONFIGURE_ARGS+= --with-iodbc --with-odbcinst=${LOCALBASE}/etc/libiodbc
.endif
USE_GMAKE= YES