aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-odbc
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-04 23:47:46 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-04 23:47:46 +0000
commit92fabe63bda5d3493d691cace35f2d1c0bedccb5 (patch)
treed54ba830677f23cbe95e99231958e28484c945cd /databases/postgresql-odbc
parent8f87e4c8f35845bc9d7ee99e6ba8282f8e2b0dfe (diff)
downloadports-92fabe63bda5d3493d691cace35f2d1c0bedccb5.tar.gz
ports-92fabe63bda5d3493d691cace35f2d1c0bedccb5.zip
Notes
Diffstat (limited to 'databases/postgresql-odbc')
-rw-r--r--databases/postgresql-odbc/Makefile32
-rw-r--r--databases/postgresql-odbc/distinfo1
-rw-r--r--databases/postgresql-odbc/pkg-descr8
-rw-r--r--databases/postgresql-odbc/pkg-plist10
4 files changed, 28 insertions, 23 deletions
diff --git a/databases/postgresql-odbc/Makefile b/databases/postgresql-odbc/Makefile
index 47af052a083c..1b764f477d83 100644
--- a/databases/postgresql-odbc/Makefile
+++ b/databases/postgresql-odbc/Makefile
@@ -1,22 +1,23 @@
-# New ports collection makefile for: PostgreSQL JDBC
+# New ports collection makefile for: PostgreSQL ODBC
# Date created: January 14, 2002
# Whom: Palle Girgensohn <girgen@partitur.se>
#
# $FreeBSD$
#
-PORTNAME= postgresql-odbc
+PORTNAME= postgresql
+PORTVERSION= 7.2.5
CATEGORIES= databases
+MASTER_SITES= http://odbc.postgresql.org/ftpsite/odbc/versions/src/
+PKGNAMESUFFIX?= -odbc
+DISTNAME= psqlodbc-${PORTVERSION}
+DIST_SUBDIR= postgresql
-MAINTAINER= girgen@partitur.se
+MAINTAINER= girgen@pingpong.net
+POSTGRESQL_PORT?= databases/postgresql7
POSTGRESQL_SUBPORT=YES
-.include <${.CURDIR}/../postgresql7/Makefile>
-
-CONFIGURE_ARGS= --with-libdir=${LOCALBASE}/lib \
- --with-includes=${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-MAKE_ARGS= LDFLAGS=${LDFLAGS}
+.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
# PostgreSQL ODBC support needs an ODBC driver manager to be
# installed, and it supports both iODBC and unixODBC. The following
@@ -30,16 +31,21 @@ DRIVER_MANAGER?= iodbc
# folks say their is the best, so you might be better off removing
# the others?
.if ${DRIVER_MANAGER} == "unixodbc"
+PKGNAMESUFFIX= -unixodbc
CONFIGURE_ARGS+= --with-unixodbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-PLIST_SUB+=UNIXODBC="" IODBC="@comment "
.else # assume we're using iodbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+= --with-iodbc --with-odbcinst=${LOCALBASE}/etc/libiodbc
-PLIST_SUB+=UNIXODBC="@comment " IODBC=""
.endif
-MAKEFILE= GNUmakefile
-MAKE_ARGS+= -C src/interfaces/odbc
+USE_GMAKE= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --with-libdir=${LOCALBASE}/lib --enable-pthreads \
+ --with-includes=${LOCALBASE}/include
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.mk>
diff --git a/databases/postgresql-odbc/distinfo b/databases/postgresql-odbc/distinfo
new file mode 100644
index 000000000000..b05cf2f75d36
--- /dev/null
+++ b/databases/postgresql-odbc/distinfo
@@ -0,0 +1 @@
+MD5 (postgresql/psqlodbc-7.2.5.tar.gz) = 701c7c55831652d35937c2efaeaab26d
diff --git a/databases/postgresql-odbc/pkg-descr b/databases/postgresql-odbc/pkg-descr
index 1c37fe2013ca..9b5c90589f70 100644
--- a/databases/postgresql-odbc/pkg-descr
+++ b/databases/postgresql-odbc/pkg-descr
@@ -2,8 +2,10 @@ Support connecting to a postgresql database from a unix client
application using ODBC.
Note: You do not need this port installed on unix if you want to use
-ODBC to connect a Windows machine with PostgreSQL.
+ODBC to connect a Windows machine to PostgreSQL.
-This software is part of the standard PostgreSQL distribution.
+Since there is an ambition to slim the PostgreSQL distribution, this
+software is no longer a part thereof. It is still the offical ODBC
+implementation, though.
-WWW: http://www.postgresql.org/
+WWW: http://odbc.postgresql.org/
diff --git a/databases/postgresql-odbc/pkg-plist b/databases/postgresql-odbc/pkg-plist
index d04b78a6bf2a..f9c8a2a2b38f 100644
--- a/databases/postgresql-odbc/pkg-plist
+++ b/databases/postgresql-odbc/pkg-plist
@@ -1,9 +1,5 @@
-%%IODBC%%lib/libpsqlodbc.so
-%%IODBC%%lib/libpsqlodbc.a
-%%IODBC%%lib/libpsqlodbc.so.0
-%%UNIXODBC%%lib/libodbcpsql.so
-%%UNIXODBC%%lib/libodbcpsql.a
-%%UNIXODBC%%lib/libodbcpsql.so.0
+lib/psqlodbc.so
+lib/psqlodbc.la
share/postgresql/odbc.sql
share/postgresql/odbc-drop.sql
-@unexec rmdir %D/share/postgresql 2>/dev/null || true
+@dirrm share/psqlodbc