aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-plpython
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
commit34fa6c853efa04ca648d3d4187d4aec40a00fc0d (patch)
tree3445b3e9b6e7650fd127ec078394a0d7a8e79076 /databases/postgresql-plpython
parentae2c26ad44dba87dd1377d70dfb1906132114c7b (diff)
downloadports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.tar.gz
ports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.zip
Notes
Diffstat (limited to 'databases/postgresql-plpython')
-rw-r--r--databases/postgresql-plpython/Makefile33
-rw-r--r--databases/postgresql-plpython/files/patch-plpython-Makefile11
-rw-r--r--databases/postgresql-plpython/pkg-plist2
3 files changed, 26 insertions, 20 deletions
diff --git a/databases/postgresql-plpython/Makefile b/databases/postgresql-plpython/Makefile
index 63a600a7ca54..821eb01b3660 100644
--- a/databases/postgresql-plpython/Makefile
+++ b/databases/postgresql-plpython/Makefile
@@ -5,21 +5,40 @@
# $FreeBSD$
#
+PORTNAME= postgresql
+PORTREVISION= 1
CATEGORIES= databases python
PKGNAMESUFFIX= -plpython
MAINTAINER= dd@FreeBSD.org
COMMENT= A module for using Python to write SQL functions
-POSTGRESQL_PORT?= databases/postgresql7
-POSTGRESQL_SUBPORT=YES
-.include "../../${POSTGRESQL_PORT}/Makefile"
-
RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
-USE_PYTHON= yes
+MASTERDIR= ${.CURDIR}/../postgresql${PGSQL_VER}-server
+
+DEFAULT_PGSQL_VER?=74
+
+# can't include <bsd.port.pre.mk> in a slave port
+# so set these instead:
+LOCALBASE?= ${DESTDIR}/usr/local
+SED?= /usr/bin/sed
-MAKE_ARGS+= -C src/pl/plpython
+# Setting/finding PostgreSQL version we want.
+.if exists(${LOCALBASE}/bin/postmaster)
+PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/postmaster.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+.elif exists(${LOCALBASE}/bin/pg_config)
+PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+.else
+PGSQL_VER= ${DEFAULT_PGSQL_VER}
+.endif
+
+USE_PYTHON= yes
CONFIGURE_ARGS= --with-python
-.include <bsd.port.mk>
+BUILD_DIRS= src/pl/plpython
+SLAVE_ONLY= yes
+
+POSTGRESQL_PORT=databases/postgresql${PGSQL_VER}-server
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql-plpython/files/patch-plpython-Makefile b/databases/postgresql-plpython/files/patch-plpython-Makefile
deleted file mode 100644
index a1303151170a..000000000000
--- a/databases/postgresql-plpython/files/patch-plpython-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/pl/plpython/Makefile~ Thu Mar 4 08:06:19 2004
-+++ src/pl/plpython/Makefile Thu Mar 4 08:06:44 2004
-@@ -8,7 +8,7 @@
- # On some platforms we can only build PL/Python if libpython is a
- # shared library. Since there is no official way to determine this,
- # we see if there is a file that is named like a shared library.
--ifneq (,$(wildcard $(python_configdir)/libpython*$(DLSUFFIX)*))
-+ifneq (,$(wildcard $(python_configdir)/../../libpython*$(DLSUFFIX)*))
- shared_libpython = yes
- endif
-
diff --git a/databases/postgresql-plpython/pkg-plist b/databases/postgresql-plpython/pkg-plist
deleted file mode 100644
index 2e953a0a80d3..000000000000
--- a/databases/postgresql-plpython/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/postgresql/plpython.so
-@unexec rmdir %D/lib/postgresql 2>/dev/null || true