aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-pltcl
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-12-04 12:00:49 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-12-04 12:00:49 +0000
commit8a928af72d1ebb839a332158c27129b8a154275e (patch)
treec658c0da17e05366791dbe372c9e966663a70265 /databases/postgresql-pltcl
parent75d6fb12df9343cebb166dc9ac575ae77c24dd4d (diff)
downloadports-8a928af72d1ebb839a332158c27129b8a154275e.tar.gz
ports-8a928af72d1ebb839a332158c27129b8a154275e.zip
Notes
Diffstat (limited to 'databases/postgresql-pltcl')
-rw-r--r--databases/postgresql-pltcl/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index 8a405a5fdda3..dad6b501987e 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -4,31 +4,23 @@
#
# $FreeBSD$
#
-POSTGRESQL_PORT?= databases/postgresql7
-PORTNAME= postgresql
-PORTVERSION!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V PORTVERSION
-PORTREVISION?= 0
-CATEGORIES= databases tcl83
-MASTER_SITES= ${MASTER_SITE_PGSQL}
-MASTER_SITE_SUBDIR!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V MASTER_SITE_SUBDIR
+PORTREVISION= 0
+CATEGORIES= databases tcl${TCLVERSION:S/.//}
PKGNAMESUFFIX= -pltcl
-DISTFILES!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V DISTFILES
-DIST_SUBDIR= postgresql
MAINTAINER= girgen@pingpong.net
COMMENT= A module for using Tcl to write SQL functions
+POSTGRESQL_PORT?= databases/postgresql7
+POSTGRESQL_SUBPORT=YES
+.include "../../${POSTGRESQL_PORT}/Makefile"
+
LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
-MD5_FILE= ${.CURDIR}/../../${POSTGRESQL_PORT}/distinfo
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
-TCLVERSION?= 8.3
+TCLVERSION?= 8.4
CONFIGURE_ARGS= --with-tcl --without-tk \
--with-tclconfig="${TCLCONFIG}" \
--with-includes="${TCL_INCDIR}"