aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql74-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-02-19 12:07:46 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-02-19 12:07:46 +0000
commit9c89540227221ee9001868542fa9f8e5bdceae53 (patch)
tree7fa5d33d41d8fe5a91a045cac4c4fd5fe5cb3764 /databases/postgresql74-server
parent8ec660dae71854839f7a6eb559f9034cfa405c3f (diff)
downloadports-9c89540227221ee9001868542fa9f8e5bdceae53.tar.gz
ports-9c89540227221ee9001868542fa9f8e5bdceae53.zip
Notes
Diffstat (limited to 'databases/postgresql74-server')
-rw-r--r--databases/postgresql74-server/Makefile18
-rw-r--r--databases/postgresql74-server/files/patch-src-pl-plpgsql-src-gram-y77
2 files changed, 86 insertions, 9 deletions
diff --git a/databases/postgresql74-server/Makefile b/databases/postgresql74-server/Makefile
index ece8e1062e8d..bd24cd934c1f 100644
--- a/databases/postgresql74-server/Makefile
+++ b/databases/postgresql74-server/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= postgresql
PKGNAMESUFFIX?= -server
PORTVERSION?= 7.4.7
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${PORTVERSION}
@@ -26,6 +26,9 @@ CONFLICTS?= ${PORTNAME}${PKGNAMESUFFIX}-7.[0-35-9]* \
WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
+UNIQUENAME?= ${PORTNAME}74
+LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
+
PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
USE_BZIP2= YES
USE_GMAKE= YES
@@ -71,20 +74,17 @@ CONFIGURE_ARGS+=--with-openssl
.if !defined(SLAVE_ONLY)
# gnugetopt will always be used if already installed
-. if (${OSVERSION} < 500041) && !exists(${LOCALBASE}/include/getopt.h)
+. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
OPTIONS+= GNUGETOPT "Use GNU getopt" on
. endif
-. if defined(SERVER_ONLY)
-OPTIONS+= PAM "Build with PAM support" off
-. endif
+# Note: server only options are no-ops for the client
+OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal kerberos support" off
OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
-. if defined(SERVER_ONLY)
-OPTIONS+= LIBC_R "Link with libc_r, needed by plpython" off
+OPTIONS+= LIBC_R "Link w/ libc_r, used by plpython (server)" off
# to run regression tests:
-OPTIONS+= TESTS "Allows the use of a \"check\" target" off
-. endif
+OPTIONS+= TESTS "Allows the use of a \"check\" target (server)" off
OPTIONS+= DEBUG "Builds with debugging symbols" off
. if defined(SERVER_ONLY) && defined(WITH_PAM)
diff --git a/databases/postgresql74-server/files/patch-src-pl-plpgsql-src-gram-y b/databases/postgresql74-server/files/patch-src-pl-plpgsql-src-gram-y
new file mode 100644
index 000000000000..053c44d5baf8
--- /dev/null
+++ b/databases/postgresql74-server/files/patch-src-pl-plpgsql-src-gram-y
@@ -0,0 +1,77 @@
+--- src/pl/plpgsql/src/gram.y 2005/01/21 00:31:21 1.48.2.1 REL7_4_7
++++ src/pl/plpgsql/src/gram.y 2005/02/08 18:22:11 1.48.2.3 REL7_4_STABLE
+@@ -4,7 +4,7 @@
+ * procedural language
+ *
+ * IDENTIFICATION
+- * $Header: /cvsroot/pgsql/src/pl/plpgsql/src/gram.y,v 1.48.2.1 2005/01/21 00:31:21 neilc Exp $
++ * $Header: /cvsroot/pgsql/src/pl/plpgsql/src/gram.y,v 1.48.2.3 2005/02/08 18:22:11 tgl Exp $
+ *
+ * This software is copyrighted by Jan Wieck - Hamburg.
+ *
+@@ -1699,6 +1699,16 @@ read_sql_construct(int until,
+ }
+ if (plpgsql_SpaceScanned)
+ plpgsql_dstring_append(&ds, " ");
++
++ /* Check for array overflow */
++ if (nparams >= 1024)
++ {
++ plpgsql_error_lineno = lno;
++ ereport(ERROR,
++ (errcode(ERRCODE_PROGRAM_LIMIT_EXCEEDED),
++ errmsg("too many variables specified in SQL statement")));
++ }
++
+ switch (tok)
+ {
+ case T_VARIABLE:
+@@ -1856,6 +1866,15 @@ make_select_stmt(void)
+
+ while ((tok = yylex()) == ',')
+ {
++ /* Check for array overflow */
++ if (nfields >= 1024)
++ {
++ plpgsql_error_lineno = plpgsql_scanner_lineno();
++ ereport(ERROR,
++ (errcode(ERRCODE_PROGRAM_LIMIT_EXCEEDED),
++ errmsg("too many INTO variables specified")));
++ }
++
+ tok = yylex();
+ switch(tok)
+ {
+@@ -1906,6 +1925,16 @@ make_select_stmt(void)
+
+ if (plpgsql_SpaceScanned)
+ plpgsql_dstring_append(&ds, " ");
++
++ /* Check for array overflow */
++ if (nparams >= 1024)
++ {
++ plpgsql_error_lineno = plpgsql_scanner_lineno();
++ ereport(ERROR,
++ (errcode(ERRCODE_PROGRAM_LIMIT_EXCEEDED),
++ errmsg("too many variables specified in SQL statement")));
++ }
++
+ switch (tok)
+ {
+ case T_VARIABLE:
+@@ -1989,6 +2018,15 @@ make_fetch_stmt(void)
+
+ while ((tok = yylex()) == ',')
+ {
++ /* Check for array overflow */
++ if (nfields >= 1024)
++ {
++ plpgsql_error_lineno = plpgsql_scanner_lineno();
++ ereport(ERROR,
++ (errcode(ERRCODE_PROGRAM_LIMIT_EXCEEDED),
++ errmsg("too many INTO variables specified")));
++ }
++
+ tok = yylex();
+ switch(tok)
+ {