aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql80-contrib
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2010-05-20 15:43:39 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2010-05-20 15:43:39 +0000
commitdaea94a3e118c8b89d6818a084c495eaf998b797 (patch)
tree019a66fdda0a13c1c8f878e18ae84364d152bacf /databases/postgresql80-contrib
parentede0dbbfacbf99a04116680290ab78dcfbc32308 (diff)
downloadports-daea94a3e118c8b89d6818a084c495eaf998b797.tar.gz
ports-daea94a3e118c8b89d6818a084c495eaf998b797.zip
Notes
Diffstat (limited to 'databases/postgresql80-contrib')
-rw-r--r--databases/postgresql80-contrib/Makefile33
-rw-r--r--databases/postgresql80-contrib/pkg-descr23
2 files changed, 56 insertions, 0 deletions
diff --git a/databases/postgresql80-contrib/Makefile b/databases/postgresql80-contrib/Makefile
new file mode 100644
index 000000000000..096e7d1efad7
--- /dev/null
+++ b/databases/postgresql80-contrib/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: postgresql-contrib
+# Date created: June 10, 2003
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -contrib
+CATEGORIES= databases
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= The contrib utilities from the PostgreSQL distribution
+
+USE_PGSQL= yes
+DEFAULT_PGSQL_VER=80
+MASTERDIR= ${.CURDIR}/../postgresql${DEFAULT_PGSQL_VER}-server
+
+USE_BISON= build
+
+BUILD_DIRS= src/port contrib
+INSTALL_DIRS= contrib
+
+SLAVE_ONLY= yes
+
+post-install:
+ @- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/ipc_check/ipc_check.pl ${PREFIX}/bin/ipc_check ;\
+ ${INSTALL_DATA} ${WRKSRC}/contrib/ipc_check/README ${DOCSDIR}/contrib/README.ipc_check ;\
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/reindexdb/reindexdb ${PREFIX}/bin/reindexdb ;\
+ ${INSTALL_DATA} ${WRKSRC}/contrib/reindexdb/README ${DOCSDIR}/contrib/README.reindexdb ;\
+ ${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/README
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql80-contrib/pkg-descr b/databases/postgresql80-contrib/pkg-descr
new file mode 100644
index 000000000000..f7a01fd35e15
--- /dev/null
+++ b/databases/postgresql80-contrib/pkg-descr
@@ -0,0 +1,23 @@
+This is the port for all stuff that comes in the contrib subtree of
+the postgresql distribution. This subtree contains porting tools,
+analysis utilities, and plug-in features that are not part of the core
+PostgreSQL system, mainly because they address a limited audience or
+are too experimental to be part of the main source tree. This does
+not preclude their usefulness.
+
+Each subdirectory contains a README file with information about the
+module. Some directories supply new user-defined functions, operators,
+or types. After you have installed the files you need to register the
+new entities in the database system by running the commands in the
+supplied .sql file. For example,
+
+ $ psql -d dbname -f module.sql
+
+The .sql files are installed into /usr/local/share/postgresql/contrib
+
+For more information, please see
+/usr/local/share/doc/postgresql/contrib/README*
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: http://www.postgresql.org/