aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql81-server/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2008-06-12 23:46:07 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2008-06-12 23:46:07 +0000
commit89025407ac8aa413884e5a33322957c188ca0a40 (patch)
tree02f0c0fbc1b0c6f9cdb6cd06fbdc74eb75df3d0c /databases/postgresql81-server/Makefile
parent03eb28a4abf15888c1e3827049e931c46a5a2399 (diff)
downloadports-89025407ac8aa413884e5a33322957c188ca0a40.tar.gz
ports-89025407ac8aa413884e5a33322957c188ca0a40.zip
Notes
Diffstat (limited to 'databases/postgresql81-server/Makefile')
-rw-r--r--databases/postgresql81-server/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index 56cf8433c02d..d494bc76d2c4 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= postgresql
-PORTVERSION?= 8.1.11
-PORTREVISION?= 1
+PORTVERSION?= 8.1.13
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${PORTVERSION}
@@ -39,11 +38,15 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS+=--with-libraries=${LOCALBASE}/lib \
--with-includes=${LOCALBASE}/include \
+ --enable-thread-safety \
--with-docdir=${DOCSDIR}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+
PLIST= ${PKGDIR}/pkg-plist${PKGNAMESUFFIX}
BUILD_DIRS?= src/port src/timezone src/backend src/backend/utils/mb/conversion_procs \
@@ -81,8 +84,6 @@ OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal kerberos support" off
OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
-OPTIONS+= LIBC_R "Link w/ libc_r, used by plpython (server)" off
-OPTIONS+= THREADSAFE "make libpq thread safe" off
# to run regression tests:
OPTIONS+= TESTS "Allows the use of a \"check\" target (server)" off
OPTIONS+= DEBUG "Builds with debugging symbols" off
@@ -168,17 +169,9 @@ CONFIGURE_ARGS+=--with-krb5
. endif
. if (defined(SERVER_ONLY) && defined(WITH_TESTS)) || make(makesum)
-EXTRA_PATCHES= ${FILESDIR}/regresspatch-src-test-regress-pgregress-sh
-. endif
-
-. if defined(WITH_THREADSAFE)
-CONFIGURE_ARGS+=--enable-thread-safety
+EXTRA_PATCHES= ${FILESDIR}/regresspatch-src-test-regress-pgregress-sh
. endif
-. if defined(SERVER_ONLY) && defined(WITH_LIBC_R)
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-. endif
.endif # !SLAVE_ONLY
.if ${ARCH} == sparc64 && ${OSVERSION} < 700000