aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql83-server
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-10-21 20:36:31 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-10-21 20:36:31 +0000
commitb183630b8705ad45482f0d82cfda8a9e426e3672 (patch)
treeadfb78f1e3447947cbf3dbfd26ad616da59645a6 /databases/postgresql83-server
parent9711b990b44beb1aff3b664144ad9ddf8ce06a5e (diff)
downloadports-b183630b8705ad45482f0d82cfda8a9e426e3672.tar.gz
ports-b183630b8705ad45482f0d82cfda8a9e426e3672.zip
Notes
Diffstat (limited to 'databases/postgresql83-server')
-rw-r--r--databases/postgresql83-server/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index b42f1b66832b..1fe31a1fd907 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= postgresql
DISTVERSION?= 8.3.16
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -81,16 +81,6 @@ MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
-# Cannot check this with standard OPTION due to a catch-22.
-# USE_OPENSSL must precede bsd.port.pre.mk, but then we don't know
-# what OPTIONS are set.
-#
-# If you *don't* want SSL, set WITHOUT_SSL=YES when making
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl
-.endif
-
.if !defined(SLAVE_ONLY)
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
@@ -107,9 +97,15 @@ OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" off
+OPTIONS+= SSL "Build with OpenSSL support" on
.endif # !SLAVE_ONLY
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl
+.endif
.if !defined(SLAVE_ONLY)
. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
@@ -120,7 +116,11 @@ PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
PATCHFILES+= pg-8311-icu-xx-2010-05-14.diff.gz:icu
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
+.endif # !SLAVE_ONLY
+
+.include <bsd.port.pre.mk>
+.if !defined(SLAVE_ONLY)
PATCH_DIST_STRIP=-p1
. if defined(WITH_PAM)