aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql84-server/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 18:08:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 18:08:52 +0000
commitb5482324dcf6b062151cc203cef1561f8923c859 (patch)
treeac2afa8997fbb76350bd6fad85df12e98e0b3da5 /databases/postgresql84-server/Makefile
parent667b4f4d18ac09226dc683a91597de9b41837f21 (diff)
downloadports-b5482324dcf6b062151cc203cef1561f8923c859.tar.gz
ports-b5482324dcf6b062151cc203cef1561f8923c859.zip
Notes
Diffstat (limited to 'databases/postgresql84-server/Makefile')
-rw-r--r--databases/postgresql84-server/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 968b41d98702..ef96b6793785 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -127,7 +127,7 @@ USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS+=--with-icu
PATCH_SITES+= http://people.freebsd.org/~crees/postgresql-icu/:icu
PATCHFILES+= ${ICU_PATCHFILE}:icu
-LIB_DEPENDS+= icudata.50:${PORTSDIR}/devel/icu
+LIB_DEPENDS+= libicudata.so:${PORTSDIR}/devel/icu
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
.endif # !SLAVE_ONLY
@@ -154,7 +154,7 @@ USE_OPENLDAP= yes
. if ${PORT_OPTIONS:MXML}
CONFIGURE_ARGS+=--with-libxml
-LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
. endif
. if ${PORT_OPTIONS:MTZDATA}
@@ -212,7 +212,7 @@ IGNORE= requires that you remove heimdal's /usr/bin/krb5-config and /usr/lib/lib
. if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a) && exists(${KRB5_HOME}/bin/krb5-config)
CONFIGURE_ARGS+=--with-krb5
. else
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= libkrb5.so.3:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+=--with-krb5
. endif
. endif
@@ -225,7 +225,7 @@ CONFIGURE_ARGS+=--with-krb5
# Postgresql apps will not link properly when libpq is linked with base heimdal in /usr,
# so we always use the heimdal port. See
# http://lists.freebsd.org/pipermail/freebsd-stable/2005-October/018809.html
-LIB_DEPENDS+= krb5.26:${PORTSDIR}/security/heimdal
+LIB_DEPENDS+= libkrb5.so.26:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+=--with-krb5
. endif
. endif