aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql84-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-11-14 23:59:26 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-11-14 23:59:26 +0000
commit170eff296f2cb45b4f81e396d73feff4692a604f (patch)
tree3c08011ee5a0f2842f7da4e4efc3ed1e062fc741 /databases/postgresql84-server
parent3a1a53f3f6308be7006b1f1b0da7c72780b16a07 (diff)
downloadports-170eff296f2cb45b4f81e396d73feff4692a604f.tar.gz
ports-170eff296f2cb45b4f81e396d73feff4692a604f.zip
Notes
Diffstat (limited to 'databases/postgresql84-server')
-rw-r--r--databases/postgresql84-server/Makefile33
1 files changed, 17 insertions, 16 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index a8c6aad8b867..171f826d37a5 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -150,28 +150,29 @@ INSTALL_TARGET= install-strip
. endif
. if defined(WITH_MIT_KRB5)
-. if exists(/usr/lib/libkrb5.so)
-BROKEN= "You must remove heimdal's /usr/lib/libkrb5.so* to build successfully with MIT-KRB"
+. if exists(/usr/lib/libkrb5.so) || exists(/usr/bin/krb5-config)
+BROKEN= "You must remove heimdal's /usr/bin/krb5-config and /usr/lib/libkrb5.so*, and set NO_KERBEROS=true in /etc/make.conf to build successfully with MIT-KRB"
. endif
-WITH_KRB5= yes
-KRB5_HOME?= ${LOCALBASE}
-KRB5CONF= ${KRB5_HOME}/bin/krb5-config
+# Allow defining a home built MIT Kerberos by setting KRB5_HOME
+. if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a) && exists(${KRB5_HOME}/bin/krb5-config)
+CONFIGURE_ARGS+=--with-krb5
+. else
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+CONFIGURE_ARGS+=--with-krb5
+. endif
. endif
. if defined(WITH_HEIMDAL_KRB5)
-WITH_KRB5= yes
-# Base heimdal in /usr will not link properly with postgresql, we must
-# use the port. See
+# Allow defining a home built Heimdal Kerberos by setting HEIMDAL_HOME
+. if defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a) && exists(${HEIMDAL_HOME}/bin/krb5-config)
+CONFIGURE_ARGS+=--with-krb5
+. else
+# Postgresql apps will not link properly when libpq is linked with base heimdal in /usr,
+# so we always use the heimdal port. See
# http://lists.freebsd.org/pipermail/freebsd-stable/2005-October/018809.html
-LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
-KRB5CONF= ${LOCALBASE}/bin/krb5-config
-. endif
-
-. if defined(WITH_KRB5)
-CONFIGURE_ARGS+= --with-krb5
-LIBS= `${KRB5CONF} --libs krb5`
-CONFIGURE_ENV+= LIBS="${LIBS}"
+LIB_DEPENDS+= krb5.20:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+=--with-krb5
+. endif
. endif
. if defined(SERVER_ONLY) && defined(WITH_TESTS)