aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql90-contrib
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2010-09-20 13:46:47 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2010-09-20 13:46:47 +0000
commitc6dcf7810701cd84940844dc8471aa35a71bd7e9 (patch)
tree964e3f53a0c4b96f862cc877659918515e4fd55f /databases/postgresql90-contrib
parent8d9c1f04433e467443da7373363ebe36af0b49d8 (diff)
downloadports-c6dcf7810701cd84940844dc8471aa35a71bd7e9.tar.gz
ports-c6dcf7810701cd84940844dc8471aa35a71bd7e9.zip
Notes
Diffstat (limited to 'databases/postgresql90-contrib')
-rw-r--r--databases/postgresql90-contrib/Makefile31
-rw-r--r--databases/postgresql90-contrib/pkg-descr23
2 files changed, 54 insertions, 0 deletions
diff --git a/databases/postgresql90-contrib/Makefile b/databases/postgresql90-contrib/Makefile
new file mode 100644
index 000000000000..d3a7e68dfe50
--- /dev/null
+++ b/databases/postgresql90-contrib/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: postgresql-contrib
+# Date created: June 10, 2003
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -contrib
+CATEGORIES= databases
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= The contrib utilities from the PostgreSQL distribution
+
+USE_PGSQL= yes
+DEFAULT_PGSQL_VER=90
+MASTERDIR= ${.CURDIR}/../postgresql${DEFAULT_PGSQL_VER}-server
+
+USE_BISON= build
+
+BUILD_DIRS= src/port contrib
+INSTALL_DIRS= contrib
+
+SLAVE_ONLY= yes
+CONFIGURE_ARGS+=--with-libxslt --with-libxml
+LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt xml2.5:${PORTSDIR}/textproc/libxml2
+
+post-install:
+ @- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/README
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql90-contrib/pkg-descr b/databases/postgresql90-contrib/pkg-descr
new file mode 100644
index 000000000000..f7a01fd35e15
--- /dev/null
+++ b/databases/postgresql90-contrib/pkg-descr
@@ -0,0 +1,23 @@
+This is the port for all stuff that comes in the contrib subtree of
+the postgresql distribution. This subtree contains porting tools,
+analysis utilities, and plug-in features that are not part of the core
+PostgreSQL system, mainly because they address a limited audience or
+are too experimental to be part of the main source tree. This does
+not preclude their usefulness.
+
+Each subdirectory contains a README file with information about the
+module. Some directories supply new user-defined functions, operators,
+or types. After you have installed the files you need to register the
+new entities in the database system by running the commands in the
+supplied .sql file. For example,
+
+ $ psql -d dbname -f module.sql
+
+The .sql files are installed into /usr/local/share/postgresql/contrib
+
+For more information, please see
+/usr/local/share/doc/postgresql/contrib/README*
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: http://www.postgresql.org/