aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql90-plperl
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-02-19 19:21:02 +0000
committerChris Rees <crees@FreeBSD.org>2012-02-19 19:21:02 +0000
commit4faae88624910d5e8aa873bf1aad9d04918c76dd (patch)
tree68ae6a985b8e82778a8aeb7ef7f5152ae94f45da /databases/postgresql90-plperl
parent3fecce1e66ed4f57903efcbf5f5dc880a82c8718 (diff)
Notes
Diffstat (limited to 'databases/postgresql90-plperl')
-rw-r--r--databases/postgresql90-plperl/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/databases/postgresql90-plperl/Makefile b/databases/postgresql90-plperl/Makefile
new file mode 100644
index 000000000000..fdd98fad3822
--- /dev/null
+++ b/databases/postgresql90-plperl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: PostgreSQL PL/Perl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+CATEGORIES= databases perl5
+PKGNAMESUFFIX= -plperl
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Write SQL functions for PostgreSQL using Perl5
+
+MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER}-server
+
+RUN_DEPENDS= postgres:${PORTSDIR}/databases/postgresql${WANT_PGSQL_VER}-server
+
+WANT_PGSQL_VER?=90
+
+USE_PERL5= yes
+CONFIGURE_ARGS= --with-perl
+
+BUILD_DIRS= src/backend src/pl/plperl
+INSTALL_DIRS= src/pl/plperl
+SLAVE_ONLY= yes
+
+.include "${MASTERDIR}/Makefile"