aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql90-server/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-10-06 08:45:16 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-10-06 08:45:16 +0000
commit8a9cb57c66cd170518c958b985b260bcdd123be7 (patch)
tree8b0062a8182debc31a6058a82e2c3a0d37c76377 /databases/postgresql90-server/Makefile
parent3bd8a2ca225060d0108056b0e3af4de8edbf90d4 (diff)
downloadports-8a9cb57c66cd170518c958b985b260bcdd123be7.tar.gz
ports-8a9cb57c66cd170518c958b985b260bcdd123be7.zip
Notes
Diffstat (limited to 'databases/postgresql90-server/Makefile')
-rw-r--r--databases/postgresql90-server/Makefile41
1 files changed, 21 insertions, 20 deletions
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 672e02d19f58..e3f181ce9914 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= postgresql
DISTVERSION?= 9.0.4
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -72,16 +72,6 @@ MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
-# Cannot check this with standard OPTION due to a catch-22.
-# USE_OPENSSL must precede bsd.port.pre.mk, but then we don't know
-# what OPTIONS are set.
-#
-# If you *don't* want SSL, set WITHOUT_SSL=YES when making
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl
-.endif
-
.if !defined(SLAVE_ONLY)
OPTIONS+= DTRACE "Build with DTrace probes (server only)" off
OPTIONS+= PAM "Build with PAM support (server only)" off
@@ -92,7 +82,7 @@ OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
OPTIONS+= XML "Build with XML data type (server)" on
OPTIONS+= TZDATA "Use internal timezone database (server)" on
OPTIONS+= DEBUG "Builds with debugging symbols" off
-OPTIONS+= GSSAPI "BUild with GSSAPI support" off
+OPTIONS+= GSSAPI "Build with GSSAPI support" off
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
OPTIONS+= ICU "Use ICU for unicode collation (server)" off
@@ -100,9 +90,15 @@ OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
+OPTIONS+= SSL "Build with OpenSSL support" on
.endif # !SLAVE_ONLY
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl
+.endif
.if !defined(SLAVE_ONLY)
. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
@@ -113,6 +109,11 @@ PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
LIB_DEPENDS+= icudata.48:${PORTSDIR}/devel/icu
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
+.endif # !SLAVE_ONLY
+
+.include <bsd.port.pre.mk>
+
+.if !defined(SLAVE_ONLY)
PATCH_DIST_STRIP=-p1
@@ -183,7 +184,7 @@ CONFIGURE_ARGS+=--without-gssapi
. if defined(WITH_MIT_KRB5)
. if exists(/usr/lib/libkrb5.so) || exists(/usr/bin/krb5-config)
-BROKEN= "You must remove heimdal's /usr/bin/krb5-config and /usr/lib/libkrb5.so*, and set NO_KERBEROS=true in /etc/make.conf to build successfully with MIT-KRB"
+BROKEN= You must remove heimdal's /usr/bin/krb5-config and /usr/lib/libkrb5.so*, and set NO_KERBEROS=true in /etc/make.conf to build successfully with MIT-KRB
. endif
# Allow defining a home built MIT Kerberos by setting KRB5_HOME
. if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a) && exists(${KRB5_HOME}/bin/krb5-config)
@@ -318,12 +319,12 @@ SUB_FILES+= pkg-message${PKGNAMESUFFIX}
PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
. endif
. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-install${PKGNAMESUFFIX}
-SUB_LIST= PG_GROUP=$(PG_GROUP) \
- PG_USER=$(PG_USER) \
- PG_UID=$(PG_UID)
-PLIST_SUB+= PG_USER=$(PG_USER)
-PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
+SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+SUB_LIST= PG_GROUP=${PG_GROUP} \
+ PG_USER=${PG_USER} \
+ PG_UID=${PG_UID}
+PLIST_SUB+= PG_USER=${PG_USER}
+PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
. endif
.endif