aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql91-server
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-10-10 00:09:35 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-10-10 00:09:35 +0000
commit284d8b86830ae0392efe8ea2fd65a3ccdf952a42 (patch)
tree70cdf6e4ee0fea6e38e7defbc7e3ce9db69ed0ef /databases/postgresql91-server
parent0ee5bfde1c3d2376c79e35486246423618b4f0cf (diff)
downloadports-284d8b86830ae0392efe8ea2fd65a3ccdf952a42.tar.gz
ports-284d8b86830ae0392efe8ea2fd65a3ccdf952a42.zip
Notes
Diffstat (limited to 'databases/postgresql91-server')
-rw-r--r--databases/postgresql91-server/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index c5356f8edf1a..f08853c3694c 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -7,15 +7,16 @@ PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= PGSQL
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX?= ${DISTV:S/.//}-server
+DISTV= ${DISTVERSION:R}
MAINTAINER?= pgsql@FreeBSD.org
COMMENT?= The most advanced open-source database available anywhere
-CONFLICTS?= ${PORTNAME}-client-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-[^${PORTVERSION:R:R}].* \
- ${PORTNAME}-client-9.[^${PORTVERSION:R:E}].* \
- ${PORTNAME}${PKGNAMESUFFIX}-9.[^${PORTVERSION:R:E}].*
+CONFLICTS?= ${PORTNAME}[^${PORTVERSION:R:R}]-client.* \
+ ${PORTNAME}${COMPONENT}[^${PORTVERSION:R:R}].* \
+ ${PORTNAME}9.[^${PORTVERSION:R:E}].*-client.* \
+ ${PORTNAME}${COMPONENT}9.[^${PORTVERSION:R:E}].*
WRKSRC= ${WRKDIR}/postgresql-${DISTVERSION}
DIST_SUBDIR= postgresql
@@ -24,13 +25,11 @@ ICU_PATCHFILE?= pg-910-icu-2012-12-19.diff.gz
.if !defined(SLAVE_ONLY)
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
.else # Contrib has different options from -client/-server
UNIQUENAME?= ${PORTNAME}${DISTVERSION:R:S/.//}${PKGNAMESUFFIX}
-LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}
.endif
-PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
+PKGINSTALL?= ${PKGDIR}/pkg-install${COMPONENT}
USE_BZIP2= yes
.if !defined(NO_BUILD)
USES+= gmake
@@ -51,7 +50,7 @@ CONFIGURE_ENV+= INCLUDES="${INCLUDES}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
LDFLAGS_SL="${LDFLAGS_SL}"
-PLIST= ${PKGDIR}/pkg-plist${PKGNAMESUFFIX}
+PLIST= ${PKGDIR}/pkg-plist${COMPONENT}
INSTALL_DIRS?= src/timezone src/backend \
src/backend/utils/mb/conversion_procs \
@@ -62,6 +61,7 @@ INSTALL_DIRS?= src/timezone src/backend \
BUILD_DIRS?= src/port ${INSTALL_DIRS}
.if !defined(CLIENT_ONLY) && !defined(SLAVE_ONLY)
+COMPONENT= -server
SERVER_ONLY= yes
USE_RC_SUBR= postgresql
USE_PGSQL= yes
@@ -341,12 +341,12 @@ do-build:
cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE}; \
done
-. if exists(${FILESDIR}/pkg-message${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-message${PKGNAMESUFFIX}
-PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-message${COMPONENT}.in)
+SUB_FILES+= pkg-message${COMPONENT}
+PKGMESSAGE= ${WRKSRC}/pkg-message${COMPONENT}
. endif
-. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+. if exists(${FILESDIR}/pkg-install${COMPONENT}.in)
+SUB_FILES+= pkg-install${COMPONENT}
PLIST_SUB+= PG_USER=${PG_USER}
. endif
@@ -374,7 +374,7 @@ do-install:
. endif
@ if [ -r ${PKGMESSAGE} ]; then \
${MKDIR} ${DOCSDIR} ;\
- ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${PKGNAMESUFFIX} ;\
+ ${INSTALL_DATA} ${PKGMESSAGE} ${DOCSDIR}/README${COMPONENT} ;\
${CAT} ${PKGMESSAGE} ;\
fi
.endif # !NO_BUILD