aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql91-server
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-07-24 06:05:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-07-24 06:05:22 +0000
commit15a9b4d2cb17aa26e0057c09fedee33ccbee66f6 (patch)
treea368777ad92dca7fba2eb52385b3bbbd59f4f0ff /databases/postgresql91-server
parent137a7b8538c7949af108c8bdbf2775a57472ccfa (diff)
downloadports-15a9b4d2cb17aa26e0057c09fedee33ccbee66f6.tar.gz
ports-15a9b4d2cb17aa26e0057c09fedee33ccbee66f6.zip
Notes
Diffstat (limited to 'databases/postgresql91-server')
-rw-r--r--databases/postgresql91-server/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index e49b4a4cf755..2268a74fe11f 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -136,6 +136,13 @@ INTDATE_CONFIGURE_OFF=--disable-integer-datetimes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+LDAP_CONFIGURE_WITH= ldap
+LDAP_USE= OPENLDAP=yes
+
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -funroll-loops
+
+DEBUG_CONFIGURE_ENABLE= debug
+
PLIST_SUB+= PG_USER=${PG_USER} \
PG_GROUP=${PG_GROUP}
SUB_LIST+= PG_GROUP=${PG_GROUP} \
@@ -166,16 +173,6 @@ IGNORE= need userland DTrace support found in FreeBSD 9.0
. endif
. endif
-. if defined (SERVER_ONLY)
-LDAP_CONFIGURE_WITH= ldap
-LDAP_USE= OPENLDAP=yes
-. endif
-
-
-OPTIMIZED_CFLAGS_CFLAGS= -O3 -funroll-loops
-
-DEBUG_CONFIGURE_ENABLE= debug
-
.if ${PORT_OPTIONS:MGSSAPI}
CONFIGURE_ARGS+=--with-gssapi
.if empty(PORT_OPTIONS:MMIT_KRB5) && empty(PORT_OPTIONS:MHEIMDAL_KRB5)