aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql92-server/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2011-04-18 23:34:27 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2011-04-18 23:34:27 +0000
commit73c856222edb8c22377bf9a1c81a724065e3a31c (patch)
tree2a77e52eec6ad4963a7f80ea0b338e506c5e9a85 /databases/postgresql92-server/Makefile
parent0953b320a922e578d792b56c3fedf8c37e6776aa (diff)
Update PostgreSQL to 9.0.4, 8.4.8, 8.3.15 and 8.2.21.
This update contains a critical fix to the pg_upgrade utility which prevents significant downtime issues. Do not use pg_upgrade without installing this update first. The issue with pg_upgrade and the fix are detailed on the PostgreSQL wiki: http://wiki.postgresql.org/wiki/20110408pg_upgrade_fix Users who have already used pg_upgrade should run the database repair script given on that page on their databases as soon as possible. See the release notes for each version at http://www.postgresql.org/docs/current/static/release.html for a full list of changes with details. Allow the username of the postgresql user to configurable for 8.4 and 9.0. Largely inspired by the work of Jason Helfman [153668, 153136]. Change PGUSER knob to PG_USER not to clash with PGUSER environment. PR: 153668, 153136, 155493, 155137
Notes
Notes: svn path=/head/; revision=272900
Diffstat (limited to 'databases/postgresql92-server/Makefile')
-rw-r--r--databases/postgresql92-server/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 52fcd0eb0bc0..21b88acbf291 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= postgresql
-DISTVERSION?= 9.0.3
+DISTVERSION?= 9.0.4
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -24,7 +24,6 @@ DIST_SUBDIR= postgresql
UNIQUENAME?= ${PORTNAME}90
LATEST_LINK?= ${PKGNAMEPREFIX}${UNIQUENAME}${PKGNAMESUFFIX}
-PKGINSTALL?= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
USE_BZIP2= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -33,8 +32,9 @@ GNU_CONFIGURE= YES
.undef GNU_CONFIGURE
.endif
-PGUSER= pgsql
-PGGROUP= pgsql
+PG_USER?= pgsql
+PG_GROUP?= pgsql
+PG_UID?= 70
LDFLAGS+= -L${LOCALBASE}/lib
INCLUDES+= -I${LOCALBASE}/include
@@ -60,6 +60,7 @@ SERVER_ONLY= yes
USE_RC_SUBR= postgresql
USE_PGSQL= yes
WANT_PGSQL_VER= ${PORTVERSION:C/([0-9][0-9]*)\.([0-9][0-9]*).*/\1\2/g}
+SUB_FILES+= 502.pgsql
.endif
.if !defined(SLAVE_ONLY)
@@ -93,7 +94,7 @@ OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
OPTIONS+= XML "Build with XML data type (server)" on
OPTIONS+= TZDATA "Use internal timezone database (server)" on
OPTIONS+= DEBUG "Builds with debugging symbols" off
-OPTIONS+= GSSAPI "BUild with GSSAPI support" on
+OPTIONS+= GSSAPI "BUild with GSSAPI support" off
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
OPTIONS+= ICU "Use ICU for unicode collation (server)" off
@@ -283,7 +284,7 @@ MAN7= ABORT.7 ALTER_AGGREGATE.7 ALTER_CONVERSION.7 ALTER_DATABASE.7 \
.if defined(SERVER_ONLY)
pre-everything::
- @${SH} ${PKGINSTALL} ${PORTNAME} BACKUPWARNING
+ @${SH} ${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in ${PORTNAME} BACKUPWARNING
.endif
.if !defined(NO_BUILD)
@@ -305,11 +306,19 @@ do-build:
SUB_FILES+= pkg-message${PKGNAMESUFFIX}
PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
. endif
+. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
+SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+SUB_LIST= PG_GROUP=$(PG_GROUP) \
+ PG_USER=$(PG_USER) \
+ PG_UID=$(PG_UID)
+PLIST_SUB+= PG_USER=$(PG_USER)
+PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
+. endif
.endif
.if defined(SERVER_ONLY)
pre-su-install:
- @ ${SETENV} PKG_PREFIX=${PREFIX} PGUSER=${PGUSER} PGGROUP=${PGGROUP} \
+ @ ${SETENV} PKG_PREFIX=${PREFIX} PG_USER=$(PG_USER) PG_GROUP=$(PG_GROUP) \
${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
.endif
@@ -330,7 +339,7 @@ do-install:
. if defined(SERVER_ONLY)
@ ${MKDIR} ${PREFIX}/share/postgresql ;\
${MKDIR} ${PREFIX}/etc/periodic/daily ;\
- ${INSTALL_SCRIPT} ${FILESDIR}/502.pgsql \
+ ${INSTALL_SCRIPT} ${WRKDIR}/502.pgsql \
${PREFIX}/etc/periodic/daily
. endif # SERVER_ONLY
. if defined(CLIENT_ONLY)