aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql92-server/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2016-10-27 14:04:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2016-10-27 14:04:55 +0000
commit57c3f72fc137af2e08f70911d5ed32924f3b515c (patch)
tree5b347bd82f15f9cd341b9b99255952e73ecfa7e6 /databases/postgresql92-server/Makefile
parent62ffe2f72b389373575c343ffbd8cc1df6fbb036 (diff)
Update PostgreSQL to latest versions.
The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 9.6.1, 9.5.5, 9.4.10, 9.3.15, 9.2.19, and 9.1.24. This release fixes two issues that can cause data corruption, which are described in more detail below. It also patches a number of other bugs reported over the last three months. The project urges users to apply this update at the next possible downtime.
Notes
Notes: svn path=/head/; revision=424765
Diffstat (limited to 'databases/postgresql92-server/Makefile')
-rw-r--r--databases/postgresql92-server/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 53d3bfae23d3..9341deb76ee8 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME?= postgresql
-DISTVERSION?= 9.2.18
-PORTREVISION?= 1
+DISTVERSION?= 9.2.19
+PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= PGSQL/source/v${DISTVERSION}
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}${COMPONENT}
MAINTAINER?= pgsql@FreeBSD.org
-COMMENT?= The most advanced open-source database available anywhere
+COMMENT?= PostgreSQL is the most advanced open-source database available anywhere
+
+LICENSE= PostgreSQL
CONFLICTS?= ${PORTNAME}[^${PORTVERSION:R:R}]?-client* \
${PORTNAME}${COMPONENT}-[^${PORTVERSION:R:R}].* \
@@ -106,7 +108,6 @@ GSSAPI_DESC= Build with GSSAPI support
OPTIMIZED_CFLAGS_DESC= Builds with compiler optimizations (-O3)
DEBUG_DESC= Builds with debugging symbols
-
OPTIONS_DEFINE+= SSL
SSL_DESC= Build with OpenSSL support
@@ -244,9 +245,6 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily ;\
${INSTALL_SCRIPT} ${WRKDIR}/502.pgsql \
${STAGEDIR}${PREFIX}/etc/periodic/daily
-. if ${PORTVERSION:M9.[2345].*}
- ${MKDIR} ${STAGEDIR}${PREFIX}/${PG_USER}
-. endif
. endif # SERVER_ONLY
. if defined(CLIENT_ONLY)
@ cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-local