aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql92-server/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2016-01-13 10:36:22 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2016-01-13 10:36:22 +0000
commita9c901ec2bd7061cb5a9f38c4aa1b4608c00cf1f (patch)
tree2f136fd2ec2358b046f3f49ea848fa2ba7711c62 /databases/postgresql92-server/Makefile
parent1a2923e25f010530a7576108fcf5f48601944a80 (diff)
Some binaries where moved from contrib to base in 9.5, like pgbench and
pg_upgrade. Other where added in 9.5, but the port failed to install them. Make sure they are properly installed by the correct port (-client or -server) [1] Remove unused and hence confusing OSSP_UUID parameters from Makefile [2] Add options to allow user to be set for the backup script in periodic. Add this option only to 9.5 for now. It will be updated to other servers at next regular patch release. [3] The path to perl in hard coded into pgxs/src/Makefile.global which is then installed. Hence, we must depend on perl when that file is installed. Noticed by: Paul Guyot [1] PR: 192387 [2] PR: 172110 [3] PR: 206046 [4]
Notes
Notes: svn path=/head/; revision=406034
Diffstat (limited to 'databases/postgresql92-server/Makefile')
-rw-r--r--databases/postgresql92-server/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index ebfee4af1707..cfa562837f67 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -67,6 +67,8 @@ SUB_FILES+= 502.pgsql
.if defined(CLIENT_ONLY)
OPTIONS_DEFINE+=LIBEDIT
LIBEDIT_DESC= Use non-GPL libedit instead of readline
+USES+= perl5
+PORTREVISION?= 1
.else
MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
@@ -120,9 +122,6 @@ LIBEDIT_USES_OFF= readline
SSL_USE= OPENSSL=yes
SSL_CONFIGURE_WITH=openssl
-OSSP_UUID_BUILD_DEPENDS= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
-OSSP_UUID_CONFIGURE_WITH= ossp-uuid
-
PAM_CONFIGURE_WITH= pam
XML_CONFIGURE_WITH= libxml