aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql93-server
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2018-02-08 17:38:36 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2018-02-08 17:38:36 +0000
commit955b7d13bc3c846c8db5252aba9551900f2bcd5a (patch)
treed01da9b8d4a814953d381a2a12a15e65949b0e1a /databases/postgresql93-server
parenta02d810ddf2142464912bba35d6ba99ff2dc2599 (diff)
Update to latest versions of PostgreSQL
2018-02-08 Security Update Release ================================== The PostgreSQL Global Development Group has released an update to all supported versions of our database system, including 10.2, 9.6.7, 9.5.11, 9.4.16, 9.3.21. This release fixes two security issues. This release also fixes issues with VACUUM, GIN indexes, and hash indexes that could lead to data corruption, as well as fixes for using parallel queries and logical replication. All users using the affected versions of PostgreSQL should update as soon as possible. Please see the notes on "Updating" below for any post-update steps that may be required. Please note that PostgreSQL changed its versioning scheme with the release of version 10.0, so updating to version 10.2 from 10.0 or 10.1 is considered a minor update. Security Issues --------------- Two security vulnerabilities have been fixed by this release: * CVE-2018-1052: Fix the processing of partition keys containing multiple expressions * CVE-2018-1053: Ensure that all temporary files made with "pg_upgrade" are non-world-readable Local fixes to the FreeBSD ports -------------------------------- Inform users about data checksums [1]. Make sure /usr/bin/su is used regardless of PATH settings [2]. Enable DTRACE by default [3]. PR: 214671 [1], 223157 [2], 215028 [3] Security: c602c791-0cf4-11e8-a2ec-6cc21735f730
Notes
Notes: svn path=/head/; revision=461251
Diffstat (limited to 'databases/postgresql93-server')
-rw-r--r--databases/postgresql93-server/Makefile10
-rw-r--r--databases/postgresql93-server/distinfo6
-rw-r--r--databases/postgresql93-server/files/pkg-message-server.in7
-rw-r--r--databases/postgresql93-server/files/postgresql.in6
-rw-r--r--databases/postgresql93-server/pkg-plist-server1
5 files changed, 21 insertions, 9 deletions
diff --git a/databases/postgresql93-server/Makefile b/databases/postgresql93-server/Makefile
index fa0b57bf8891..3f44456fa9ca 100644
--- a/databases/postgresql93-server/Makefile
+++ b/databases/postgresql93-server/Makefile
@@ -1,7 +1,7 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
# $FreeBSD$
-DISTVERSION?= 9.3.20
+DISTVERSION?= 9.3.21
PORTREVISION= 0
PKGNAMESUFFIX?= ${DISTVERSION:R:S/.//}${COMPONENT}
@@ -14,6 +14,10 @@ INSTALL_DIRS?= src/common src/timezone src/backend \
src/bin/pg_controldata src/bin/pg_resetxlog src/pl \
src/bin/pg_basebackup
-ICU_PATCHFILE?= pg-9314-icu-2016-08-10.diff.gz
+ICU_PATCHFILE= pg-9314-icu-2016-08-10.diff.gz
-.include "${.CURDIR}/../postgresql92-server/Makefile"
+PG_USER?= pgsql
+PG_GROUP?= pgsql
+PG_UID?= 70
+
+.include "${.CURDIR}/../postgresql10-server/Makefile"
diff --git a/databases/postgresql93-server/distinfo b/databases/postgresql93-server/distinfo
index 26b1ea54a492..72361e89dea2 100644
--- a/databases/postgresql93-server/distinfo
+++ b/databases/postgresql93-server/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1510172181
-SHA256 (postgresql/postgresql-9.3.20.tar.bz2) = eb138ad67075b8acb4fae56e98ca7be5d85f3da0ba658fc48206834598a2e6ca
-SIZE (postgresql/postgresql-9.3.20.tar.bz2) = 17197360
+TIMESTAMP = 1517868536
+SHA256 (postgresql/postgresql-9.3.21.tar.bz2) = b9babc5148188a410e023d7178a5678e989ec2e276498de6cd0028bc331a40e0
+SIZE (postgresql/postgresql-9.3.21.tar.bz2) = 17014472
SHA256 (postgresql/pg-9314-icu-2016-08-10.diff.gz) = 4be31ad9899d5caf9f57ad7ebfc0d14f0fcf58ad539c82fb353b016fb76c0c30
SIZE (postgresql/pg-9314-icu-2016-08-10.diff.gz) = 5583
diff --git a/databases/postgresql93-server/files/pkg-message-server.in b/databases/postgresql93-server/files/pkg-message-server.in
index d161fcb82f66..8df5b8198903 100644
--- a/databases/postgresql93-server/files/pkg-message-server.in
+++ b/databases/postgresql93-server/files/pkg-message-server.in
@@ -50,6 +50,13 @@ For postmaster settings, see ~pgsql/data/postgresql.conf
NB. FreeBSD's PostgreSQL port logs to syslog by default
See ~pgsql/data/postgresql.conf for more info
+NB. If you're not using a checksumming filesystem like ZFS, you might
+ wish to enable data checksumming. It can only be enabled during
+ the initdb phase, by adding the "--data-checksums" flag to
+ the postgres_initdb_flags rcvar. Check the initdb(1) manpage
+ for more info and make sure you understand the performance
+ implications.
+
======================================================================
To run PostgreSQL at startup, add
diff --git a/databases/postgresql93-server/files/postgresql.in b/databases/postgresql93-server/files/postgresql.in
index b6724571bd29..f6ea340f7f0f 100644
--- a/databases/postgresql93-server/files/postgresql.in
+++ b/databases/postgresql93-server/files/postgresql.in
@@ -50,6 +50,8 @@ status_cmd="postgresql_command status"
initdb_cmd="postgresql_initdb"
+su_cmd="/usr/bin/su"
+
if [ -n "$2" ]; then
profile="$2"
if [ "x${postgresql_profiles}" != "x" ]; then
@@ -103,12 +105,12 @@ command_args="-D ${postgresql_data} ${postgresql_flags}"
postgresql_command()
{
- su -l ${postgresql_user} -c "exec ${command} ${command_args} ${rc_arg}"
+ ${su_cmd} -l ${postgresql_user} -c "exec ${command} ${command_args} ${rc_arg}"
}
postgresql_initdb()
{
- su -l -c ${postgresql_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data} -U ${postgresql_user}"
+ ${su_cmd} -l -c ${postgresql_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data} -U ${postgresql_user}"
}
run_rc_command "$1"
diff --git a/databases/postgresql93-server/pkg-plist-server b/databases/postgresql93-server/pkg-plist-server
index 37df7ad46aac..35a801c19031 100644
--- a/databases/postgresql93-server/pkg-plist-server
+++ b/databases/postgresql93-server/pkg-plist-server
@@ -714,7 +714,6 @@ lib/libpgcommon.a
%%TZDATA%%%%DATADIR%%/timezone/US/Michigan
%%TZDATA%%%%DATADIR%%/timezone/US/Mountain
%%TZDATA%%%%DATADIR%%/timezone/US/Pacific
-%%TZDATA%%%%DATADIR%%/timezone/US/Pacific-New
%%TZDATA%%%%DATADIR%%/timezone/US/Samoa
%%TZDATA%%%%DATADIR%%/timezone/UTC
%%TZDATA%%%%DATADIR%%/timezone/Universal