aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql95-plpython
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-07-01 17:45:51 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-07-01 17:45:51 +0000
commit7e35b9708ad6f43dc4643b50fdd37f1e0c515d6f (patch)
tree148ea1cb5bafd59bba901288259a57c805dccd25 /databases/postgresql95-plpython
parent38793c3b6c825052aba54af75d517a7bcdf62c2f (diff)
downloadports-7e35b9708ad6f43dc4643b50fdd37f1e0c515d6f.tar.gz
ports-7e35b9708ad6f43dc4643b50fdd37f1e0c515d6f.zip
Notes
Diffstat (limited to 'databases/postgresql95-plpython')
-rw-r--r--databases/postgresql95-plpython/Makefile30
-rw-r--r--databases/postgresql95-plpython/pkg-descr6
2 files changed, 34 insertions, 2 deletions
diff --git a/databases/postgresql95-plpython/Makefile b/databases/postgresql95-plpython/Makefile
index 5d8c735d4cfe..115b776bde4c 100644
--- a/databases/postgresql95-plpython/Makefile
+++ b/databases/postgresql95-plpython/Makefile
@@ -1,5 +1,31 @@
# $FreeBSD$
-WANT_PGSQL_VER= 9.5
+PORTNAME= postgresql
+CATEGORIES= databases python
+PKGNAMESUFFIX?= ${DISTVERSION:R:S/.//}${COMPONENT}
-.include "${.CURDIR}/../postgresql90-plpython/Makefile"
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= Module for using Python to write SQL functions
+
+USES+= pgsql:${WANT_PGSQL_VER} ${WANT_PYTHON_USE}
+WANT_PGSQL= server
+
+MASTERDIR= ${.CURDIR}/../postgresql${WANT_PGSQL_VER:S/.//}-server
+
+WANT_PGSQL_VER?= 9.5
+WANT_PYTHON_USE?= python
+
+CONFIGURE_ARGS= --with-python
+COMPONENT= -plpython
+
+.if defined(PYTHON_VER) && ${PYTHON_VER:R} == 3
+PLIST_SUB+= PYTHON2="@comment " PYTHON3=""
+.else
+PLIST_SUB+= PYTHON2="" PYTHON3="@comment "
+.endif
+
+BUILD_DIRS= src/backend src/pl/plpython
+INSTALL_DIRS= src/pl/plpython
+SLAVE_ONLY= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql95-plpython/pkg-descr b/databases/postgresql95-plpython/pkg-descr
new file mode 100644
index 000000000000..1e121bca492d
--- /dev/null
+++ b/databases/postgresql95-plpython/pkg-descr
@@ -0,0 +1,6 @@
+PL/Python allows one to write PostgeSQL stored functions and
+procedures in Python (http://www.python.org/).
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: http://www.postgresql.org/