aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql96-contrib
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2016-09-05 11:15:29 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2016-09-05 11:15:29 +0000
commit96150e27d7c316bc1d0b148d004b7fb036b7c5b3 (patch)
treec9c81cfb306dbdbcfdfd66b3af8892ccea273a81 /databases/postgresql96-contrib
parentf69161cef9f81e7b73433f421299d066bd0c17ba (diff)
downloadports-96150e27d7c316bc1d0b148d004b7fb036b7c5b3.tar.gz
ports-96150e27d7c316bc1d0b148d004b7fb036b7c5b3.zip
Notes
Diffstat (limited to 'databases/postgresql96-contrib')
-rw-r--r--databases/postgresql96-contrib/Makefile32
-rw-r--r--databases/postgresql96-contrib/pkg-descr23
2 files changed, 55 insertions, 0 deletions
diff --git a/databases/postgresql96-contrib/Makefile b/databases/postgresql96-contrib/Makefile
new file mode 100644
index 000000000000..55ed6d09223b
--- /dev/null
+++ b/databases/postgresql96-contrib/Makefile
@@ -0,0 +1,32 @@
+# Created by: Palle Girgensohn <girgen@pingpong.net>
+# $FreeBSD$
+
+PORTNAME= postgresql
+PORTREVISION= 0
+CATEGORIES= databases
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= The contrib utilities from the PostgreSQL distribution
+
+LIB_DEPENDS= libxslt.so:textproc/libxslt \
+ libxml2.so:textproc/libxml2
+
+MASTERDIR= ${.CURDIR}/../postgresql96-server
+
+USES= bison pgsql:9.6
+
+BUILD_DIRS= src/port src/include src/common contrib
+INSTALL_DIRS= contrib
+
+SLAVE_ONLY= yes
+COMPONENT= -contrib
+CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls --with-uuid=bsd
+LDFLAGS+= -lpthread -L${PREFIX}/lib
+
+post-configure:
+ @cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks
+
+post-install:
+ @- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/extension/README
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql96-contrib/pkg-descr b/databases/postgresql96-contrib/pkg-descr
new file mode 100644
index 000000000000..f7a01fd35e15
--- /dev/null
+++ b/databases/postgresql96-contrib/pkg-descr
@@ -0,0 +1,23 @@
+This is the port for all stuff that comes in the contrib subtree of
+the postgresql distribution. This subtree contains porting tools,
+analysis utilities, and plug-in features that are not part of the core
+PostgreSQL system, mainly because they address a limited audience or
+are too experimental to be part of the main source tree. This does
+not preclude their usefulness.
+
+Each subdirectory contains a README file with information about the
+module. Some directories supply new user-defined functions, operators,
+or types. After you have installed the files you need to register the
+new entities in the database system by running the commands in the
+supplied .sql file. For example,
+
+ $ psql -d dbname -f module.sql
+
+The .sql files are installed into /usr/local/share/postgresql/contrib
+
+For more information, please see
+/usr/local/share/doc/postgresql/contrib/README*
+
+This software is part of the standard PostgreSQL distribution.
+
+WWW: http://www.postgresql.org/