aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql_autodoc/Makefile
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-05-13 21:50:51 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-05-13 21:50:51 +0000
commit8ca9c4d132f2421f2680ea1419592ae4c388873e (patch)
treee9de4c26c98f269b5d4f831f7263ca92e7b43e46 /databases/postgresql_autodoc/Makefile
parent171c607e51ccd160c49281b653a9da015699cb8f (diff)
Notes
Diffstat (limited to 'databases/postgresql_autodoc/Makefile')
-rw-r--r--databases/postgresql_autodoc/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/databases/postgresql_autodoc/Makefile b/databases/postgresql_autodoc/Makefile
index 81dc87f50663..bfcee30e6fbe 100644
--- a/databases/postgresql_autodoc/Makefile
+++ b/databases/postgresql_autodoc/Makefile
@@ -6,26 +6,31 @@
#
PORTNAME= postgresql_autodoc
-PORTVERSION= 1.01
+PORTVERSION= 1.10.b1
CATEGORIES= databases
MASTER_SITES= http://www.rbt.ca/autodoc/
+DISTFILES= ${PORTNAME}-1.10b1.tar.gz
+DIST_SUBDIR= postgresql
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Automatic documentation generator for postgresql databases
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
-USE_REINPLACE= yes
+USE_AUTOCONF_VER= 253
+USE_GMAKE= yes
USE_PERL5= yes
NO_BUILD= yes
+CONFIGURE_ARGS+= --datadir=${DATADIR}
-WRKSRC= ${WRKDIR}
+WRKSRC= ${WRKDIR}/postgresql_autodoc
-post-patch:
- @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/postgresql_autodoc.pl
+# post-patch:
+# @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/postgresql_autodoc.pl
-do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/postgresql_autodoc.pl ${PREFIX}/bin/postgresql_autodoc
+# do-install:
+# @${INSTALL_SCRIPT} ${WRKSRC}/postgresql_autodoc.pl ${PREFIX}/bin/postgresql_autodoc
.include <bsd.port.mk>