aboutsummaryrefslogtreecommitdiff
path: root/databases/pxlib/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-12-11 10:33:44 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-12-11 10:33:44 +0000
commit29a419d4a6376367f52d41b3373a7f5febf9ebf0 (patch)
tree4d68e2f22b7630d94c01c06f31d53b7b09f2e1e1 /databases/pxlib/Makefile
parent37079e6393e885a1bbfb5741f81ba307c887539f (diff)
downloadports-29a419d4a6376367f52d41b3373a7f5febf9ebf0.tar.gz
ports-29a419d4a6376367f52d41b3373a7f5febf9ebf0.zip
Notes
Diffstat (limited to 'databases/pxlib/Makefile')
-rw-r--r--databases/pxlib/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/databases/pxlib/Makefile b/databases/pxlib/Makefile
new file mode 100644
index 000000000000..647ef33eaac8
--- /dev/null
+++ b/databases/pxlib/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: pxlib
+# Date created: 10 December 2005
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pxlib
+PORTVERSION= 0.5.1
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= C library to read various Paradox files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+INSTALLS_SHLIB= yes
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+OPTIONS= DOCS "Build and install documentation" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DOCS)
+BUILD_DEPENDS= docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
+ docbook2man:${PORTSDIR}/textproc/docbook-utils
+
+MAN3= PX_add_primary_index.3 PX_close.3 PX_close_blob.3 \
+ PX_create_blob_file.3 PX_create_file.3 PX_create_fp.3 \
+ PX_delete.3 PX_get_data_alpha.3 PX_get_data_bcd.3 \
+ PX_get_data_blob.3 PX_get_data_byte.3 PX_get_data_bytes.3 \
+ PX_get_data_double.3 PX_get_data_graphic.3 PX_get_data_long.3 \
+ PX_get_data_short.3 PX_get_field.3 PX_get_fields.3 \
+ PX_get_majorversion.3 PX_get_minorversion.3 PX_get_num_fields.3 \
+ PX_get_num_records.3 PX_get_opaque.3 PX_get_parameter.3 \
+ PX_get_record.3 PX_get_record2.3 PX_get_recordsize.3 \
+ PX_get_subminorversion.3 PX_get_value.3 PX_new.3 \
+ PX_new2.3 PX_new3.3 PX_new_blob.3 PX_open_blob_file.3 \
+ PX_open_blob_fp.3 PX_open_file.3 PX_open_fp.3 PX_open_gsf.3 \
+ PX_put_data_alpha.3 PX_put_data_bcd.3 PX_put_data_byte.3 \
+ PX_put_data_bytes.3 PX_put_data_double.3 PX_put_data_long.3 \
+ PX_put_data_short.3 PX_put_record.3 PX_put_recordn.3 \
+ PX_read_blobdata.3 PX_read_primary_index.3 PX_set_blob_file.3 \
+ PX_set_inputencoding.3 PX_set_parameter.3 PX_set_tablename.3 \
+ PX_set_targetencoding.3 PX_set_value.3 PX_strdup.3 \
+ PX_timestamp2string.3 PX_write_primary_index.3 pxlib.3
+.else
+pre-build:
+ ${REINPLACE_CMD} -e 's/^DOCDIR =.*/DOCDIR =/' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>