aboutsummaryrefslogtreecommitdiff
path: root/databases/py-Elixir
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-08-19 08:42:23 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-08-19 08:42:23 +0000
commit7d47557605d65c238a73ddfc53a9da8e3a21f518 (patch)
tree2ee138b6fa87c1694e4e6940ea459c5454069ee5 /databases/py-Elixir
parent6205f477f6a4afb82449848445a3b0cdc87f60a3 (diff)
downloadports-7d47557605d65c238a73ddfc53a9da8e3a21f518.tar.gz
ports-7d47557605d65c238a73ddfc53a9da8e3a21f518.zip
- Update to 0.6.1
- Add pkg-plist - Add post-install stage to install examples
Notes
Notes: svn path=/head/; revision=218821
Diffstat (limited to 'databases/py-Elixir')
-rw-r--r--databases/py-Elixir/Makefile10
-rw-r--r--databases/py-Elixir/distinfo6
-rw-r--r--databases/py-Elixir/pkg-plist49
3 files changed, 60 insertions, 5 deletions
diff --git a/databases/py-Elixir/Makefile b/databases/py-Elixir/Makefile
index d352fe6156c9..c1930415823f 100644
--- a/databases/py-Elixir/Makefile
+++ b/databases/py-Elixir/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Elixir
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.1
#PORTREVISION= 0
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP \
@@ -21,6 +21,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.4.0:${PORTSDIR}/databases/py-s
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+.if !defined(NOPORTEXAMPLES)
+EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/databases/py-Elixir/distinfo b/databases/py-Elixir/distinfo
index 8365c27f9d5f..00a8f403b197 100644
--- a/databases/py-Elixir/distinfo
+++ b/databases/py-Elixir/distinfo
@@ -1,3 +1,3 @@
-MD5 (Elixir-0.6.0.tar.gz) = b5f5cf5b8c0b98e45e903f9910b3d49e
-SHA256 (Elixir-0.6.0.tar.gz) = bf831005d28ef152ceaffe1ac68b0dd9fad5c1100ff070d0510aadd0d97043c4
-SIZE (Elixir-0.6.0.tar.gz) = 110144
+MD5 (Elixir-0.6.1.tar.gz) = af257fda955b45a7ff06144c6356bf07
+SHA256 (Elixir-0.6.1.tar.gz) = 5323ff827a0700e323deaed5815b78b007cc7c8fa87201b1093046b4e04fbace
+SIZE (Elixir-0.6.1.tar.gz) = 111188
diff --git a/databases/py-Elixir/pkg-plist b/databases/py-Elixir/pkg-plist
new file mode 100644
index 000000000000..11b7bc2d1dee
--- /dev/null
+++ b/databases/py-Elixir/pkg-plist
@@ -0,0 +1,49 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/dev.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/devdata.sqlite
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/setup.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/start-videostore.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/PKG-INFO
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/SOURCES.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/dependency_links.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/not-zip-safe
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/paster_plugins.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/requires.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/sqlobject.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore.egg-info/top_level.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/config/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/config/app.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/config/log.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/controllers/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/controllers/root.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/json.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/model.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/release.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/static/css/login.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/static/css/style.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/static/images/favicon.ico
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/static/images/info.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/static/images/ok.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/actor.kid
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/director.kid
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/index.kid
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/login.kid
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/master.kid
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/templates/movie.kid
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/tests/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/tests/test_controllers.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/videostore/videostore/tests/test_model.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/tests
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/templates
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/static/images
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/static/css
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/static
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/controllers
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore/config
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore.egg-info
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore/videostore
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/videostore
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%