aboutsummaryrefslogtreecommitdiff
path: root/databases/py-PyGreSQL
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-09-02 15:58:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-09-02 15:58:33 +0000
commit2cdc9fb6dce638a69ee731eacf5c2f4d3935ba5e (patch)
tree39af4087ce3083ef061c9285ec73de22272508d9 /databases/py-PyGreSQL
parent51f2c79e0a8a276bccac52cbaf1773516f0cadda (diff)
downloadports-2cdc9fb6dce638a69ee731eacf5c2f4d3935ba5e.tar.gz
ports-2cdc9fb6dce638a69ee731eacf5c2f4d3935ba5e.zip
Notes
Diffstat (limited to 'databases/py-PyGreSQL')
-rw-r--r--databases/py-PyGreSQL/Makefile5
-rw-r--r--databases/py-PyGreSQL/distinfo4
-rw-r--r--databases/py-PyGreSQL/files/patch-pgmodule.c24
-rw-r--r--databases/py-PyGreSQL/files/patch-setup.py13
4 files changed, 28 insertions, 18 deletions
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 879b45eef822..006229ce154c 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= PyGreSQL
-PORTVERSION= 3.4
-PORTREVISION= 1
+PORTVERSION= 3.5
PORTEPOCH= 1
CATEGORIES= databases python
MASTER_SITES= ftp://ftp.pygresql.org/pub/distrib/
@@ -15,7 +14,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
MAINTAINER= girgen@pingpong.net
-COMMENT= A Python interface to PostgreSQL, both classic interface and DP-API 2.0
+COMMENT= A Python interface to PostgreSQL, both classic and DP-API 2.0
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
diff --git a/databases/py-PyGreSQL/distinfo b/databases/py-PyGreSQL/distinfo
index 1fc1b2a47165..c4d1b41ff74f 100644
--- a/databases/py-PyGreSQL/distinfo
+++ b/databases/py-PyGreSQL/distinfo
@@ -1,2 +1,2 @@
-MD5 (PyGreSQL-3.4.tgz) = 3cd6e4b689a339748261fa714a8fcd6c
-SIZE (PyGreSQL-3.4.tgz) = 33266
+MD5 (PyGreSQL-3.5.tgz) = aec4cc8600af25b1fe895f2ee6cd9801
+SIZE (PyGreSQL-3.5.tgz) = 44884
diff --git a/databases/py-PyGreSQL/files/patch-pgmodule.c b/databases/py-PyGreSQL/files/patch-pgmodule.c
new file mode 100644
index 000000000000..1d185cf8f10b
--- /dev/null
+++ b/databases/py-PyGreSQL/files/patch-pgmodule.c
@@ -0,0 +1,24 @@
+--- pgmodule.c~ Tue Jan 13 13:29:57 2004
++++ pgmodule.c Sat Aug 28 16:41:56 2004
+@@ -27,10 +27,19 @@
+ */
+
+ #include <Python.h>
+-#include "postgres.h"
++
++/* defines snatched from "catalog/pg_type.h" */
++#define INT2OID 21
++#define INT4OID 23
++#define INT8OID 20
++#define OIDOID 26
++#define FLOAT4OID 700
++#define FLOAT8OID 701
++#define NUMERICOID 1700
++#define CASHOID 790
++
+ #include "libpq-fe.h"
+ #include "libpq/libpq-fs.h"
+-#include "catalog/pg_type.h"
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/databases/py-PyGreSQL/files/patch-setup.py b/databases/py-PyGreSQL/files/patch-setup.py
deleted file mode 100644
index 62344b3cd6ed..000000000000
--- a/databases/py-PyGreSQL/files/patch-setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- setup.py~ Tue Jan 13 13:29:57 2004
-+++ setup.py Tue Jan 13 16:14:50 2004
-@@ -30,8 +30,8 @@
- optional_libs=[ 'libpqdll', 'wsock32', 'advapi32' ]
- data_files = [ 'libpq.dll' ]
- else:
-- include_dirs=['/usr/include/pgsql']
-- library_dirs=['/usr/lib/pgsql']
-+ include_dirs=['%%LOCALBASE%%/include', '%%LOCALBASE%%/include/postgresql', '%%LOCALBASE%%/include/postgresql/server']
-+ library_dirs=['%%LOCALBASE%%/lib']
- optional_libs=['pq']
- data_files = []
-