aboutsummaryrefslogtreecommitdiff
path: root/databases/py-bsddb/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /databases/py-bsddb/Makefile
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Notes
Diffstat (limited to 'databases/py-bsddb/Makefile')
-rw-r--r--databases/py-bsddb/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/databases/py-bsddb/Makefile b/databases/py-bsddb/Makefile
index b7e69165c0ee..4dcd08594e16 100644
--- a/databases/py-bsddb/Makefile
+++ b/databases/py-bsddb/Makefile
@@ -17,7 +17,7 @@ LICENSE= PSFL
PORTSCOUT= ignore:1
USE_PYTHON= distutils autoplist
-USES= bdb python tar:xz
+USES= bdb python:2.7 tar:xz
DIST_SUBDIR= python
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
@@ -27,12 +27,6 @@ PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
MAKE_ENV= BSDDB_VERSION=${BDB_LIB_NAME}
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} >= 3000
-IGNORE= bsddb package was removed from core standard library since 3.0, use databases/py-bsddb3 instead
-.endif
-
post-extract:
@${CP} ${FILESDIR}/setup.py ${WRKSRC}
@@ -41,4 +35,4 @@ post-patch:
's,^\(#include.*\)\(db\.h.*\)$$,\1${BDB_INCLUDE_DIR}/\2,' \
${WRKSRC}/bsddb.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>