aboutsummaryrefslogtreecommitdiff
path: root/databases/py-cql/Makefile
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-07 04:12:43 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-07 04:12:43 +0000
commit2a1d91736618a59f53c6a1d78f1bee4a3b22e56d (patch)
treef43d7ab58995cc6dc69e265fa4e11688314b69cc /databases/py-cql/Makefile
parent0867160c6faa94336c7368a2d73f667356119005 (diff)
downloadports-2a1d91736618a59f53c6a1d78f1bee4a3b22e56d.tar.gz
ports-2a1d91736618a59f53c6a1d78f1bee4a3b22e56d.zip
Notes
Diffstat (limited to 'databases/py-cql/Makefile')
-rw-r--r--databases/py-cql/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/py-cql/Makefile b/databases/py-cql/Makefile
new file mode 100644
index 000000000000..414460c61824
--- /dev/null
+++ b/databases/py-cql/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-cql
+# Date created: 2011-12-14
+# Whom: Radim Kolar <hsn@fbsd8.localdomain>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cql
+PORTVERSION= 1.0.6
+CATEGORIES= databases python
+MASTER_SITES= http://cassandra-dbapi2.apache-extras.org.codespot.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+#DISTNAME= cql-${PORTVERSION}
+
+MAINTAINER= hsn@sendmail.cz
+COMMENT= Python DB-API 2.0 client interface for Cassandra
+
+LICENSE= ASL
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/thrift/Thrift.py:${PORTSDIR}/devel/py-thrift
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= cql
+
+.include <bsd.port.mk>