aboutsummaryrefslogtreecommitdiff
path: root/databases/py-geoalchemy2/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-25 07:43:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-25 07:43:01 +0000
commit9d77e1f1717cf7ade789f1f0261b4eed30d778f5 (patch)
tree4ffcd038dabbf620b322a755ff6d11a4d002809c /databases/py-geoalchemy2/Makefile
parent353f0b30557c5237e927806f549e9f87fa6b221c (diff)
Notes
Diffstat (limited to 'databases/py-geoalchemy2/Makefile')
-rw-r--r--databases/py-geoalchemy2/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/databases/py-geoalchemy2/Makefile b/databases/py-geoalchemy2/Makefile
new file mode 100644
index 000000000000..d7fbb32ab6b7
--- /dev/null
+++ b/databases/py-geoalchemy2/Makefile
@@ -0,0 +1,22 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= geoalchemy2
+PORTVERSION= 0.2.4
+CATEGORIES= databases geography python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= GeoAlchemy2-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Using SQLAlchemy with Spatial Databases
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy08>=0.8:${PORTSDIR}/databases/py-sqlalchemy-devel
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>