aboutsummaryrefslogtreecommitdiff
path: root/databases/py-htsql/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-07-23 21:14:48 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-07-23 21:14:48 +0000
commitd07965fa9866856a6255feca3df20b93d314c663 (patch)
treeacbc5d857bec83b70b87f019f34816dd5f0d2fe3 /databases/py-htsql/Makefile
parent80d9d27908425e8862794649a81bede78cce3a75 (diff)
downloadports-d07965fa9866856a6255feca3df20b93d314c663.tar.gz
ports-d07965fa9866856a6255feca3df20b93d314c663.zip
Notes
Diffstat (limited to 'databases/py-htsql/Makefile')
-rw-r--r--databases/py-htsql/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/databases/py-htsql/Makefile b/databases/py-htsql/Makefile
index 307fc94a4758..277ab38edb05 100644
--- a/databases/py-htsql/Makefile
+++ b/databases/py-htsql/Makefile
@@ -6,24 +6,23 @@
#
PORTNAME= htsql
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3.1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= HTSQL-${PORTVERSION}
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= koobs.freebsd@gmail.com
COMMENT= Python HTSQL
-USE_PYTHON= 2.5-2.7
+USE_PYTHON= 2.6-2.7
USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= HTSQL
+PYDISTUTILS_PKGNAME= ${PORTNAME:U}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/yaml/__init__.py:${PORTSDIR}/devel/py-yaml \
- ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2 \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
-post-patch:
- @${REINPLACE_CMD} -e 's|build/dist/egg|dist|g' ${WRKSRC}/setup.cfg
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>