aboutsummaryrefslogtreecommitdiff
path: root/databases/py-python-swiftclient
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /databases/py-python-swiftclient
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
Notes
Diffstat (limited to 'databases/py-python-swiftclient')
-rw-r--r--databases/py-python-swiftclient/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/databases/py-python-swiftclient/Makefile b/databases/py-python-swiftclient/Makefile
index 412aa90a75d4..d72cc4bb55fc 100644
--- a/databases/py-python-swiftclient/Makefile
+++ b/databases/py-python-swiftclient/Makefile
@@ -12,14 +12,14 @@ COMMENT= Python client library for OpenStack Object Storage (Swift)
LICENSE= APACHE20
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.21:devel/py-pbr
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.21:devel/py-pbr@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>=3.0:devel/py-futures \
- ${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}requests>=1.1:www/py-requests
+RUN_DEPENDS+= ${PY_FUTURES} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=1.1:www/py-requests@${FLAVOR}
-USES= python:2
+USES= python
USE_PYTHON= distutils autoplist
post-install: