aboutsummaryrefslogtreecommitdiff
path: root/databases/py-rrdtool_lgpl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-18 14:16:02 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-18 14:16:02 +0000
commitd03c0e3c1ec60f42df726e2652dc778f68eb33f8 (patch)
treeaa629cd55a1cfd102c3dce319cdba1c4f2215093 /databases/py-rrdtool_lgpl
parentcc1e562616a89d250bc209968047e2d770bf0a62 (diff)
downloadports-d03c0e3c1ec60f42df726e2652dc778f68eb33f8.tar.gz
ports-d03c0e3c1ec60f42df726e2652dc778f68eb33f8.zip
Notes
Diffstat (limited to 'databases/py-rrdtool_lgpl')
-rw-r--r--databases/py-rrdtool_lgpl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/databases/py-rrdtool_lgpl/Makefile b/databases/py-rrdtool_lgpl/Makefile
index e3e6e99adb80..1c91768aee1a 100644
--- a/databases/py-rrdtool_lgpl/Makefile
+++ b/databases/py-rrdtool_lgpl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rrdtool_lgpl
PORTVERSION= 1.0b1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= databases python
MASTER_SITES= SF/py-rrdtool/py-rrdtool/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,6 +12,9 @@ DISTNAME= py-rrdtool-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python interface to RRDTool, the graphing and logging utility
+LICENSE= LGPL21 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool
USES= python:2
@@ -19,4 +22,7 @@ USE_PYTHON= distutils autoplist
LIBDIR?= ${LOCALBASE}/lib # directory where librrd.so lives
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_rrdtool.so
+
.include <bsd.port.mk>