aboutsummaryrefslogtreecommitdiff
path: root/databases/py-sqlalchemy/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-23 13:47:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-23 13:47:02 +0000
commit44c5f0ff2dd8b320d3c3c3b9d133c3fcb9df49a6 (patch)
treed479ddb7a278bf0b4636731f00e0d49a5d502d33 /databases/py-sqlalchemy/Makefile
parent7481628a1eb8559f8b46bac107e04574fd0da191 (diff)
The Python SQL Toolkit and Object Relational Mapper
SQLAlchemy is the Python SQL toolkit and Object Relational Mapper that gives application developers the full power and flexibility of SQL. It provides a full suite of well known enterprise-level persistence patterns, designed for efficient and high-performing database access, adapted into a simple and Pythonic domain language. WWW: http://www.sqlalchemy.org/ PR: ports/101920 Submitted by: Dryice Liu <dryice@dryice.name> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=171275
Diffstat (limited to 'databases/py-sqlalchemy/Makefile')
-rw-r--r--databases/py-sqlalchemy/Makefile78
1 files changed, 78 insertions, 0 deletions
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
new file mode 100644
index 000000000000..08db1ab89bc8
--- /dev/null
+++ b/databases/py-sqlalchemy/Makefile
@@ -0,0 +1,78 @@
+# Ports collection makefile for: py-sqlalchemy
+# Date created: 12 Auguest 2004
+# Whom: Dryice Dong Liu <dryice@dryice.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlalchemy
+PORTVERSION= 0.2.7
+CATEGORIES= databases python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://cheeseshop.python.org/packages/source/S/SQLAlchemy/ \
+ http://dryice.name/computer/FreeBSD/distfiles/
+DISTNAME= SQLAlchemy-${PORTVERSION}
+
+MAINTAINER= dryice@dryice.name
+COMMENT= A Python SQL toolkit and Object Relational Mapper
+
+USE_PYTHON= 2.3+
+PLIST_SUB+= PORTVERSION=${PORTVERSION} \
+ PYTHONVERSION=${_PYTHON_VERSION} \
+ EXAMPLEDIR=share/examples/${PORTNAME}
+USE_PYDISTUTILS= yes
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+OPTIONS= FIREBIRD "support FireBird" off
+OPTIONS+= MSSQL "support MS SQL Server" off
+OPTIONS+= MYSQL "support MySql" on
+OPTIONS+= POSTGRE "support PostGreSQL" on
+OPTIONS+= SQLITE "support Sqlite" on
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= adv_datamapping.html alphaapi.html \
+ alphaimplementation.html datamapping.html \
+ dbengine.html docs.css docstrings.html \
+ documentation.html index.html metadata.html \
+ plugins.html pooling.html scripts.js \
+ sqlconstruction.html style.css syntaxhighlight.css \
+ tutorial.html types.html unitofwork.html
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FIREBIRD)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/kinterbasdb/__init__.py:${PORTSDIR}/databases/kinterbasdb
+.endif
+
+.if defined(WITH_MSSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pymssql.py:${PORTSDIR}/databases/py-mssql
+.endif
+
+.if !defined(WITHOUT_MYSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+.endif
+
+.if !defined(WITHOUT_POSTGRE)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
+.endif
+
+.if !defined(WITHOUT_SQLITE)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.endif
+
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in adjacencytree backref polymorph vertical
+ ${CP} -r ${WRKSRC}/examples/${i} ${EXAMPLESDIR}
+.endfor
+
+.include <bsd.port.post.mk>