aboutsummaryrefslogtreecommitdiff
path: root/databases/py-sqlalchemy06/Makefile
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-17 09:49:46 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-17 09:49:46 +0000
commit7d4b7018b8fd9709dea9fcd5cb250b6fa1816965 (patch)
tree210fccb769da4cf5d059bbfe6e5aba060476a7ec /databases/py-sqlalchemy06/Makefile
parent118d91a2647254ccd594f1671b7e5929bdf216c6 (diff)
Notes
Diffstat (limited to 'databases/py-sqlalchemy06/Makefile')
-rw-r--r--databases/py-sqlalchemy06/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/py-sqlalchemy06/Makefile b/databases/py-sqlalchemy06/Makefile
index a65a0089cbeb..19f16a9f0c15 100644
--- a/databases/py-sqlalchemy06/Makefile
+++ b/databases/py-sqlalchemy06/Makefile
@@ -6,12 +6,13 @@
#
PORTNAME= sqlalchemy
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.3
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://cheeseshop.python.org/packages/source/S/SQLAlchemy/ \
http://dryice.name/computer/FreeBSD/distfiles/
MASTER_SITE_SUBDIR= sqlalchemy
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= SQLAlchemy-${PORTVERSION}
MAINTAINER= dryice@dryice.name
@@ -35,12 +36,15 @@ OPTIONS+= SQLITE "support Sqlite" on
PORTDOCS= adv_datamapping.html alphaapi.html \
alphaimplementation.html datamapping.html \
dbengine.html docs.css docstrings.html \
- index.html metadata.html \
+ documentation.html index.html metadata.html \
plugins.html pooling.html scripts.js \
sqlconstruction.html style.css syntaxhighlight.css \
tutorial.html types.html unitofwork.html
.endif
+PORTEXAMPLES= adjacencytree association backref collections graphs \
+ pickle polymorph vertical
+
.include <bsd.port.pre.mk>
.if defined(WITH_FIREBIRD)
@@ -72,7 +76,7 @@ post-install:
.endif
${MKDIR} ${EXAMPLESDIR}
-.for i in adjacencytree backref polymorph vertical
+.for i in ${PORTEXAMPLES}
${CP} -r ${WRKSRC}/examples/${i} ${EXAMPLESDIR}
.endfor