aboutsummaryrefslogtreecommitdiff
path: root/databases/py-sqlalchemy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /databases/py-sqlalchemy
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412346
Diffstat (limited to 'databases/py-sqlalchemy')
-rw-r--r--databases/py-sqlalchemy/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
index 0625198afcbe..9ee0fe513187 100644
--- a/databases/py-sqlalchemy/Makefile
+++ b/databases/py-sqlalchemy/Makefile
@@ -15,7 +15,7 @@ COMMENT= Python SQL toolkit and Object Relational Mapper
LICENSE= MIT
TEST_DEPENDS:= ${RUN_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+ ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose
# Python3 ready
USES= python
@@ -45,33 +45,33 @@ AL_PORTDOCS_SUBDIR= core dialects orm
.endif
.if ${PORT_OPTIONS:MMSSQL}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pymssql.py:${PORTSDIR}/databases/py-mssql
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pymssql.py:databases/py-mssql
.endif
.if ${PORT_OPTIONS:MMYSQL}
.if ${PYTHON_VER} < 3.0
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
#.else
# At the moment databases/py-pymysql does not build with Python3
# See https://github.com/petehunt/PyMySQL#python-3-0-support
-#RUN_DEPENDS+= pymysql>=0.5:${PORTSDIR}/databases/py-pymysql
+#RUN_DEPENDS+= pymysql>=0.5:databases/py-pymysql
.endif
.endif
.if ${PORT_OPTIONS:MTESTS}
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose
.endif
.if ${PORT_OPTIONS:MPGSQL}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-psycopg2
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:databases/py-psycopg2
.endif
.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
.endif
.if ${PORT_OPTIONS:MSYBASE}
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Sybase.py:${PORTSDIR}/databases/py-sybase
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Sybase.py:databases/py-sybase
.endif
post-patch: