aboutsummaryrefslogtreecommitdiff
path: root/databases/py-sqlobject
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-13 09:25:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-13 09:25:45 +0000
commit713ec90dea58c68a21a7a90c7448272a35c3068d (patch)
tree92464f2d53cbd374d2a14edb372bd4d0d97d0173 /databases/py-sqlobject
parent5fc022ae1d9b78816591f7bf9a6f2cc003f88c9f (diff)
downloadports-713ec90dea58c68a21a7a90c7448272a35c3068d.tar.gz
ports-713ec90dea58c68a21a7a90c7448272a35c3068d.zip
Notes
Diffstat (limited to 'databases/py-sqlobject')
-rw-r--r--databases/py-sqlobject/Makefile10
-rw-r--r--databases/py-sqlobject/pkg-descr2
-rw-r--r--databases/py-sqlobject/pkg-plist27
3 files changed, 38 insertions, 1 deletions
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
index b3e536b31277..7e4dc6b27252 100644
--- a/databases/py-sqlobject/Makefile
+++ b/databases/py-sqlobject/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sqlobject
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,4 +24,13 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-M
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/databases/py-sqlobject/pkg-descr b/databases/py-sqlobject/pkg-descr
index 4bf213755791..323c59c50cc4 100644
--- a/databases/py-sqlobject/pkg-descr
+++ b/databases/py-sqlobject/pkg-descr
@@ -1,4 +1,4 @@
-QLObject is an object-relational mapper.
+SQLObject is an object-relational mapper.
It allows you to translate RDBMS table rows into Python objects,
and manipulate those objects to transparently manipulate the database.
diff --git a/databases/py-sqlobject/pkg-plist b/databases/py-sqlobject/pkg-plist
index 07ce197debb1..41a3de3243b4 100644
--- a/databases/py-sqlobject/pkg-plist
+++ b/databases/py-sqlobject/pkg-plist
@@ -79,6 +79,33 @@
%%PYTHON_SITELIBDIR%%/sqlobject/sybase/sybaseconnection.py
%%PYTHON_SITELIBDIR%%/sqlobject/sybase/sybaseconnection.pyc
%%PYTHON_SITELIBDIR%%/sqlobject/sybase/sybaseconnection.pyo
+%%PORTDOCS%%%%DOCSDIR%%/Authors.html
+%%PORTDOCS%%%%DOCSDIR%%/Authors.txt
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/News.html
+%%PORTDOCS%%%%DOCSDIR%%/News.txt
+%%PORTDOCS%%%%DOCSDIR%%/Plan06.html
+%%PORTDOCS%%%%DOCSDIR%%/Plan06.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/SQLBuilder.html
+%%PORTDOCS%%%%DOCSDIR%%/SQLBuilder.txt
+%%PORTDOCS%%%%DOCSDIR%%/SQLObject.html
+%%PORTDOCS%%%%DOCSDIR%%/SQLObject.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+%%PORTDOCS%%%%DOCSDIR%%/default.css
+%%PORTDOCS%%%%EXAMPLESDIR%%/codebits.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/config.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/examplestripper.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/leftjoin.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/people.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/personaddress.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/setup.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/simpleperson.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/styles.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/userrole.py
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%PYTHON_SITELIBDIR%%/sqlobject/sybase
@dirrm %%PYTHON_SITELIBDIR%%/sqlobject/sqlite
@dirrm %%PYTHON_SITELIBDIR%%/sqlobject/postgres