aboutsummaryrefslogtreecommitdiff
path: root/databases/py-txredisapi
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2020-06-02 19:13:48 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2020-06-02 19:13:48 +0000
commitdd264217ab3687e4be94bcd9cd4bc7d55e753c59 (patch)
tree48c089fd4d6a9a5e82f0b47d1b69d8b088709020 /databases/py-txredisapi
parent173e99f15ca676c3a21b7c241c473400350a687c (diff)
downloadports-dd264217ab3687e4be94bcd9cd4bc7d55e753c59.tar.gz
ports-dd264217ab3687e4be94bcd9cd4bc7d55e753c59.zip
txredisapi is a non-blocking client driver for the redis database, written in
python. It uses twisted for the asynchronous communication with redis. WWW: https://github.com/IlyaSkriblovsky/txredisapi PR: 246813 Submitted by: Sascha Biberhofer <ports@skyforge.at>
Notes
Notes: svn path=/head/; revision=537569
Diffstat (limited to 'databases/py-txredisapi')
-rw-r--r--databases/py-txredisapi/Makefile31
-rw-r--r--databases/py-txredisapi/distinfo3
-rw-r--r--databases/py-txredisapi/pkg-descr4
3 files changed, 38 insertions, 0 deletions
diff --git a/databases/py-txredisapi/Makefile b/databases/py-txredisapi/Makefile
new file mode 100644
index 000000000000..8a913e412fd4
--- /dev/null
+++ b/databases/py-txredisapi/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= txredisapi
+DISTVERSION= 1.4.7
+CATEGORIES= databases python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@skyforge.at
+COMMENT= Non-blocking redis client for python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# Keep the RUN_DEPENDS layout similar to the master/synapse/python_dependencies.py file
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=2.0:devel/py-mock@${PY_FLAVOR} \
+ redis-server:databases/redis
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= IlyaSkriblovsky
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && PYTHONPATH="." trial-${PYTHON_VER} tests
+
+.include <bsd.port.mk>
diff --git a/databases/py-txredisapi/distinfo b/databases/py-txredisapi/distinfo
new file mode 100644
index 000000000000..68407099597a
--- /dev/null
+++ b/databases/py-txredisapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1590665977
+SHA256 (IlyaSkriblovsky-txredisapi-1.4.7_GH0.tar.gz) = dfaf204ab547eeddfcf54c81734a8a06dadbbf079fd01d9c27a788c7d770376e
+SIZE (IlyaSkriblovsky-txredisapi-1.4.7_GH0.tar.gz) = 53969
diff --git a/databases/py-txredisapi/pkg-descr b/databases/py-txredisapi/pkg-descr
new file mode 100644
index 000000000000..869496f10a49
--- /dev/null
+++ b/databases/py-txredisapi/pkg-descr
@@ -0,0 +1,4 @@
+txredisapi is a non-blocking client driver for the redis database, written in
+python. It uses twisted for the asynchronous communication with redis.
+
+WWW: https://github.com/IlyaSkriblovsky/txredisapi