aboutsummaryrefslogtreecommitdiff
path: root/databases/qof
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-06 21:51:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-06 21:51:59 +0000
commit10a3b8247f6ebe8ca0987bbbd6a5febeb039ea57 (patch)
tree37a8ac39c3adf698a865ad65aaf1266a52e90ee9 /databases/qof
parentc648e191620c9ac07da8dbf147fea98726ab1c7d (diff)
downloadports-10a3b8247f6ebe8ca0987bbbd6a5febeb039ea57.tar.gz
ports-10a3b8247f6ebe8ca0987bbbd6a5febeb039ea57.zip
Notes
Diffstat (limited to 'databases/qof')
-rw-r--r--databases/qof/Makefile43
-rw-r--r--databases/qof/distinfo2
-rw-r--r--databases/qof/pkg-descr5
-rw-r--r--databases/qof/pkg-plist64
4 files changed, 114 insertions, 0 deletions
diff --git a/databases/qof/Makefile b/databases/qof/Makefile
new file mode 100644
index 000000000000..35dc7d5f2a9a
--- /dev/null
+++ b/databases/qof/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= qof
+PORTVERSION= 0.8.7
+CATEGORIES= databases
+MASTER_SITES= DEBIAN_POOL
+DISTNAME= qof_${PORTVERSION}.orig
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Query Object Framework
+
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS_INSTALL= gnotime-2.[0-3]* gnotime-2.4.0* gnotime-2.4.1 gnotime-2.4.1_[12]*
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-doxygen --disable-gdasql --disable-sqlite
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+USES= gmake libtool pathfix pkgconfig
+USE_GNOME= glib20 libxml2
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+post-patch:
+ @${REINPLACE_CMD} -e '/CFLAGS=/s|-g2||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|__isleap|qof_date_isleap|' \
+ ${WRKSRC}/qof/qofdate.c
+ @${REINPLACE_CMD} -e '/^AM_CFLAGS =/s|-g||' \
+ ${WRKSRC}/lib/libsql/Makefile.in \
+ ${WRKSRC}/qof/Makefile.in
+ @${REINPLACE_CMD} -e '/^sql_parse_test_DEPENDENCIES =/s/$$/ libqofsql.la/' \
+ ${WRKSRC}/lib/libsql/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/databases/qof/distinfo b/databases/qof/distinfo
new file mode 100644
index 000000000000..0eeca40aed02
--- /dev/null
+++ b/databases/qof/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qof_0.8.7.orig.tar.gz) = 86fd671390dc13ee6fd2e1e13775786c518b0ebff5e886f27bbd394de1e73094
+SIZE (qof_0.8.7.orig.tar.gz) = 932957
diff --git a/databases/qof/pkg-descr b/databases/qof/pkg-descr
new file mode 100644
index 000000000000..7ab086d2a59c
--- /dev/null
+++ b/databases/qof/pkg-descr
@@ -0,0 +1,5 @@
+QOF - Query Object Framework - library to add a query engine to C
+applications with generic XML backend. A SQL database is not needed; any
+collection of C/C++ objects can act as tables.
+
+WWW: https://alioth.debian.org/projects/qof/
diff --git a/databases/qof/pkg-plist b/databases/qof/pkg-plist
new file mode 100644
index 000000000000..17a8c33ba58e
--- /dev/null
+++ b/databases/qof/pkg-plist
@@ -0,0 +1,64 @@
+include/qof/guid.h
+include/qof/kvpframe.h
+include/qof/kvputil.h
+include/qof/qof-backend-qsf.h
+include/qof/qof.h
+include/qof/qofbackend-p.h
+include/qof/qofbackend.h
+include/qof/qofbook.h
+include/qof/qofbookmerge.h
+include/qof/qofchoice.h
+include/qof/qofclass.h
+include/qof/qofdate.h
+include/qof/qoferror.h
+include/qof/qofevent.h
+include/qof/qofgobj.h
+include/qof/qofid-p.h
+include/qof/qofid.h
+include/qof/qofinstance-p.h
+include/qof/qofinstance.h
+include/qof/qoflog.h
+include/qof/qofnumeric.h
+include/qof/qofobject.h
+include/qof/qofquery-p.h
+include/qof/qofquery.h
+include/qof/qofquerycore-p.h
+include/qof/qofquerycore.h
+include/qof/qofreference.h
+include/qof/qofsession.h
+include/qof/qofsql.h
+include/qof/qoftime.h
+include/qof/qofundo.h
+include/qof/qofutil.h
+include/qof/sql_parser.h
+lib/libqof.a
+lib/libqof.so
+lib/libqof.so.2
+lib/libqof.so.2.0.4
+lib/libqofsql.a
+lib/libqofsql.so
+lib/libqofsql.so.1
+lib/libqofsql.so.1.0.1
+lib/qof2/libqof-backend-qsf.a
+lib/qof2/libqof-backend-qsf.so
+libdata/pkgconfig/qof.pc
+%%NLS%%share/locale/cs/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/de/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/id/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/it/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/qof.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/qof.mo
+share/xml/qof/qsf/pilot-qsf-GnuCashInvoice.xml
+share/xml/qof/qsf/pilot-qsf-gncCustomer.xml
+share/xml/qof/qsf/qsf-map.xsd.xml
+share/xml/qof/qsf/qsf-object.xsd.xml
+@dirrm share/xml/qof/qsf
+@dirrm share/xml/qof
+@dirrm lib/qof2
+@dirrm include/qof