aboutsummaryrefslogtreecommitdiff
path: root/databases/redis-devel/files
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2014-10-10 21:18:00 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2014-10-10 21:18:00 +0000
commit0a3e78eb8c4c97a6dbe79a7c71d12ee51326f2e5 (patch)
tree49b7a54865a0d0f016347b5cdfe3bc8fb17de665 /databases/redis-devel/files
parent70852e384b48ae603e378e4feec98d2b9bdfd210 (diff)
downloadports-0a3e78eb8c4c97a6dbe79a7c71d12ee51326f2e5.tar.gz
ports-0a3e78eb8c4c97a6dbe79a7c71d12ee51326f2e5.zip
Notes
Diffstat (limited to 'databases/redis-devel/files')
-rw-r--r--databases/redis-devel/files/patch-deps-Makefile15
-rw-r--r--databases/redis-devel/files/patch-src-Makefile36
2 files changed, 31 insertions, 20 deletions
diff --git a/databases/redis-devel/files/patch-deps-Makefile b/databases/redis-devel/files/patch-deps-Makefile
index 793a03c9bc61..35e9e8aa55b3 100644
--- a/databases/redis-devel/files/patch-deps-Makefile
+++ b/databases/redis-devel/files/patch-deps-Makefile
@@ -1,17 +1,20 @@
---- deps/Makefile.orig 2012-07-02 04:18:07.000000000 +0400
-+++ deps/Makefile 2012-07-02 04:18:56.000000000 +0400
-@@ -58,12 +58,12 @@
- LUA_CFLAGS= -D__C99FEATURES__=1
+--- deps/Makefile.orig 2014-10-11 01:02:23.000000000 +0400
++++ deps/Makefile 2014-10-11 01:03:37.000000000 +0400
+@@ -58,7 +58,7 @@
+ LUA_CFLAGS= -D__C99FEATURES__=1
endif
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
+LUA_CFLAGS+= -Wall -DLUA_ANSI $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
+ # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+ # challenging to cross-compile lua (and redis). These defines make it easier
+@@ -68,7 +68,7 @@
lua: .make-prerequisites
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
-- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
-+ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
+- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
++ cd lua/src && $(MAKE) all CC="$(CC)" CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
.PHONY: lua
diff --git a/databases/redis-devel/files/patch-src-Makefile b/databases/redis-devel/files/patch-src-Makefile
index 8846533cdd23..fd370cbcddd5 100644
--- a/databases/redis-devel/files/patch-src-Makefile
+++ b/databases/redis-devel/files/patch-src-Makefile
@@ -1,7 +1,7 @@
---- src/Makefile.orig 2014-01-14 14:17:43.000000000 +0400
-+++ src/Makefile 2014-01-14 14:19:31.000000000 +0400
+--- src/Makefile.orig 2014-10-11 01:09:55.000000000 +0400
++++ src/Makefile 2014-10-11 01:12:53.000000000 +0400
@@ -22,7 +22,7 @@
- WARN=-Wall
+ WARN=-Wall -W
OPT=$(OPTIMIZATION)
-PREFIX?=/usr/local
@@ -9,23 +9,31 @@
INSTALL_BIN=$(PREFIX)/bin
INSTALL=install
-@@ -52,7 +52,7 @@
+@@ -52,7 +52,6 @@
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
-DEBUG=-g -ggdb
-+#DEBUG=-g -ggdb
ifeq ($(uname_S),SunOS)
# SunOS
-@@ -63,6 +63,7 @@
--ifeq ($(uname_S),Darwin)
-- # Darwin (nothing to do)
--else
+@@ -63,6 +62,11 @@
+ ifeq ($(uname_S),Darwin)
+ # Darwin (nothing to do)
+ else
+ifeq ($(uname_S),FreeBSD)
-+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
-+ FINAL_LDFLAGS= $(LDFLAGS)
++ # FreeBSD
++ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
++ FINAL_LDFLAGS= $(LDFLAGS)
+else
- # All the other OSes (notably Linux)
- FINAL_LDFLAGS+= -rdynamic
- FINAL_LIBS+= -pthread
+ ifeq ($(uname_S),AIX)
+ # AIX
+ FINAL_LDFLAGS+= -Wl,-bexpall
+@@ -75,6 +79,7 @@
+ endif
+ endif
+ endif
++endif
+ # Include paths to dependencies
+ FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src
+