aboutsummaryrefslogtreecommitdiff
path: root/databases/redis/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-09-20 17:46:19 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-09-20 17:46:19 +0000
commit673fc573d7425442fa208c138e2df672d3c262a1 (patch)
treed6daf5494ed5f87a27e26054046e3f8edf2772b8 /databases/redis/Makefile
parent0ecf12b8e1088a2d751f62f078402e276089f1f0 (diff)
Notes
Diffstat (limited to 'databases/redis/Makefile')
-rw-r--r--databases/redis/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 2dc49cb39206..338beffb755e 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= redis
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+DISTVERSION= 2.0.1
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
@@ -18,11 +17,12 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
CFLAGS+= -I${LOCALBASE}/include
-CONFLICTS?= redis-devel-2.*
+CONFLICTS?= redis1-1.*
USE_GMAKE= yes
USE_RC_SUBR= redis.sh
-BIN_FILES= redis-server redis-benchmark redis-cli
+BIN_FILES= redis-benchmark redis-check-aof redis-check-dump \
+ redis-cli redis-server
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-install
@@ -47,9 +47,9 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
-PATTERN= '10d;13s|$$$$(ARCH) ||'
+PATTERN= '16d;119d;15s|$$$$(ARCH) ||'
.if !defined(WITH_DEBUG)
-PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+PATTERN:= ${PATTERN:S/'$/;5s|^|\#|'/}
.endif
post-patch: