aboutsummaryrefslogtreecommitdiff
path: root/databases/redis2
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-09-20 17:46:19 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-09-20 17:46:19 +0000
commit673fc573d7425442fa208c138e2df672d3c262a1 (patch)
treed6daf5494ed5f87a27e26054046e3f8edf2772b8 /databases/redis2
parent0ecf12b8e1088a2d751f62f078402e276089f1f0 (diff)
downloadports-673fc573d7425442fa208c138e2df672d3c262a1.tar.gz
ports-673fc573d7425442fa208c138e2df672d3c262a1.zip
Notes
Diffstat (limited to 'databases/redis2')
-rw-r--r--databases/redis2/Makefile12
-rw-r--r--databases/redis2/distinfo6
-rw-r--r--databases/redis2/files/patch-redis.conf22
-rw-r--r--databases/redis2/pkg-plist4
4 files changed, 23 insertions, 21 deletions
diff --git a/databases/redis2/Makefile b/databases/redis2/Makefile
index 2dc49cb39206..338beffb755e 100644
--- a/databases/redis2/Makefile
+++ b/databases/redis2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= redis
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+DISTVERSION= 2.0.1
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
@@ -18,11 +17,12 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
CFLAGS+= -I${LOCALBASE}/include
-CONFLICTS?= redis-devel-2.*
+CONFLICTS?= redis1-1.*
USE_GMAKE= yes
USE_RC_SUBR= redis.sh
-BIN_FILES= redis-server redis-benchmark redis-cli
+BIN_FILES= redis-benchmark redis-check-aof redis-check-dump \
+ redis-cli redis-server
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-install
@@ -47,9 +47,9 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
-PATTERN= '10d;13s|$$$$(ARCH) ||'
+PATTERN= '16d;119d;15s|$$$$(ARCH) ||'
.if !defined(WITH_DEBUG)
-PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+PATTERN:= ${PATTERN:S/'$/;5s|^|\#|'/}
.endif
post-patch:
diff --git a/databases/redis2/distinfo b/databases/redis2/distinfo
index 9a3389d30aac..fe490d368ab8 100644
--- a/databases/redis2/distinfo
+++ b/databases/redis2/distinfo
@@ -1,3 +1,3 @@
-MD5 (redis-1.2.6.tar.gz) = 0c5355e57606523f9e8ce816db5e542f
-SHA256 (redis-1.2.6.tar.gz) = bed0641225f786f225a2c4897ffbec1e6573a3c31e9f899884ee3041eab96873
-SIZE (redis-1.2.6.tar.gz) = 213341
+MD5 (redis-2.0.1.tar.gz) = 7c0fd3521bbee3ba777b195dedeac5c4
+SHA256 (redis-2.0.1.tar.gz) = 4a20e667fe4267e1eb743d9b929a3662f7d5e211ef036c8dd4a7280f51a3b169
+SIZE (redis-2.0.1.tar.gz) = 347301
diff --git a/databases/redis2/files/patch-redis.conf b/databases/redis2/files/patch-redis.conf
index 4aab6fedaf65..d105b89a9e95 100644
--- a/databases/redis2/files/patch-redis.conf
+++ b/databases/redis2/files/patch-redis.conf
@@ -1,32 +1,32 @@
---- redis.conf.orig 2009-12-27 11:54:09.000000000 +0300
-+++ redis.conf 2009-12-27 11:56:16.000000000 +0300
-@@ -2,11 +2,11 @@
+--- redis.conf.orig 2010-07-02 16:00:49.000000000 +0400
++++ redis.conf 2010-07-02 16:01:46.000000000 +0400
+@@ -14,11 +14,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
-daemonize no
+daemonize yes
- # When run as a daemon, Redis write a pid file in /var/run/redis.pid by default.
- # You can specify a custom pid file location here.
+ # When running daemonized, Redis writes a pid file in /var/run/redis.pid by
+ # default. You can specify a custom pid file location here.
-pidfile /var/run/redis.pid
+pidfile %%REDIS_RUNDIR%%/redis.pid
# Accept connections on the specified port, default is 6379
port 6379
-@@ -29,7 +29,7 @@
+@@ -42,7 +42,7 @@
# Specify the log file name. Also 'stdout' can be used to force
- # the demon to log on the standard output. Note that if you use standard
+ # Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
-logfile stdout
+logfile %%REDIS_LOGDIR%%/redis.log
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
-@@ -64,7 +64,7 @@
-
- # For default save/load DB in/from the working directory
- # Note that you must specify a directory not a file name.
+@@ -86,7 +86,7 @@
+ # Also the Append Only File will be created inside this directory.
+ #
+ # Note that you must specify a directory here, not a file name.
-dir ./
+dir %%REDIS_DBDIR%%/
diff --git a/databases/redis2/pkg-plist b/databases/redis2/pkg-plist
index 3f7c08dc7eee..8391247fbe51 100644
--- a/databases/redis2/pkg-plist
+++ b/databases/redis2/pkg-plist
@@ -1,6 +1,8 @@
-bin/redis-server
bin/redis-benchmark
+bin/redis-check-aof
+bin/redis-check-dump
bin/redis-cli
+bin/redis-server
@unexec (cmp -s %D/etc/redis.conf %D/etc/redis.conf.sample && rm -f %D/etc/redis.conf) || true
etc/redis.conf.sample
@exec [ -f %B/redis.conf ] || cp %B/%f %B/redis.conf