aboutsummaryrefslogtreecommitdiff
path: root/databases/riak
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2016-09-24 14:08:48 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2016-09-24 14:08:48 +0000
commit55aec8abdb669870bd4d552c0a9bc7881839e14b (patch)
treeee5b9911aebbaf3f89728375e719624a64e1cdac /databases/riak
parent4457b85fc667dc40a1c5e2f7787336e219710914 (diff)
downloadports-55aec8abdb669870bd4d552c0a9bc7881839e14b.tar.gz
ports-55aec8abdb669870bd4d552c0a9bc7881839e14b.zip
Notes
Diffstat (limited to 'databases/riak')
-rw-r--r--databases/riak/Makefile4
-rw-r--r--databases/riak/files/patch-deps-node_package-priv-base-env.sh13
2 files changed, 9 insertions, 8 deletions
diff --git a/databases/riak/Makefile b/databases/riak/Makefile
index b99e3ab814f4..61cab647f488 100644
--- a/databases/riak/Makefile
+++ b/databases/riak/Makefile
@@ -2,13 +2,13 @@
PORTNAME= riak
PORTVERSION= 1.4.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://s3.amazonaws.com/downloads.basho.com/riak/${PORTVERSION:R}/${PORTVERSION}/ \
http://downloads.basho.com.s3.amazonaws.com/riak/${PORTVERSION:R}/${PORTVERSION}/
MAINTAINER= robak@FreeBSD.org
-COMMENT= Riak is an open source, distributed, noSQL database
+COMMENT= Open source, distributed, noSQL database
LICENSE= APACHE20
diff --git a/databases/riak/files/patch-deps-node_package-priv-base-env.sh b/databases/riak/files/patch-deps-node_package-priv-base-env.sh
index 63c53f3a6d78..75c35f00088e 100644
--- a/databases/riak/files/patch-deps-node_package-priv-base-env.sh
+++ b/databases/riak/files/patch-deps-node_package-priv-base-env.sh
@@ -1,6 +1,6 @@
---- deps/node_package/priv/base/env.sh.orig 2013-09-13 10:22:32.000000000 +0200
-+++ deps/node_package/priv/base/env.sh 2013-09-13 10:27:16.000000000 +0200
-@@ -100,7 +100,7 @@
+--- deps/node_package/priv/base/env.sh.orig 2013-11-08 18:56:54 UTC
++++ deps/node_package/priv/base/env.sh
+@@ -100,7 +100,7 @@ ping_node() {
# read/write/delete .pid files during startup/shutdown
create_pid_dir() {
# Validate RUNNER_USER is set and they have permissions to write to /var/run
@@ -9,7 +9,7 @@
if ([ "$RUNNER_USER" ] && [ "x$WHOAMI" != "x$RUNNER_USER" ]); then
if [ -w $RUN_DIR ]; then
mkdir -p $PID_DIR
-@@ -161,12 +161,12 @@
+@@ -161,12 +161,13 @@ check_user() {
# Validate that the user running the script is the owner of the
# RUN_DIR.
if ([ "$RUNNER_USER" ] && [ "x$WHOAMI" != "x$RUNNER_USER" ]); then
@@ -21,7 +21,8 @@
exit 1
fi
- exec sudo -H -u $RUNNER_USER -i $RUNNER_SCRIPT_DIR/$RUNNER_SCRIPT $@
-+ exec su - $RUNNER_USER -c "$RUNNER_SCRIPT_DIR/$RUNNER_SCRIPT $@"
++ ESCAPED_ARGS=`echo "$@" | sed -e 's/\([{}"]\)/\\\\\1/g'`
++ exec su - $RUNNER_USER -c "$RUNNER_SCRIPT_DIR/$RUNNER_SCRIPT $ESCAPED_ARGS"
fi
}
-
+