aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-15 21:49:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-15 21:49:57 +0000
commit5cb1e9be8449f597f9ab9e3a2c9408d93b57dcd4 (patch)
treebbfabf5c1e576707b2b642dc4ea0dbe12ff57f30 /databases/rrdtool/Makefile
parent095fc0cdb336be21b8a0e0d27a8de0cc763df497 (diff)
downloadports-5cb1e9be8449f597f9ab9e3a2c9408d93b57dcd4.tar.gz
ports-5cb1e9be8449f597f9ab9e3a2c9408d93b57dcd4.zip
Notes
Diffstat (limited to 'databases/rrdtool/Makefile')
-rw-r--r--databases/rrdtool/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index f5af45fc2854..34065ee050ba 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -18,15 +18,15 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
png.5:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= libtool:15
-USE_PERL5= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --enable-perl-site-install --disable-tcl
+CONFIGURE_ARGS= --disable-tcl
OPTIONS= PYTHON_MODULE "Build PYTHON bindings" off \
- RUBY_MODULE "Build RUBY bindings" off
+ RUBY_MODULE "Build RUBY bindings" off \
+ PERL_MODULE "Build PERL module" on
.include <bsd.port.pre.mk>
.if defined(WITH_PYTHON_MODULE)
@@ -49,6 +49,15 @@ CONFIGURE_ARGS+= --disable-ruby
PLIST_SUB+= WITH_RUBY="@comment "
.endif
+.if !defined(WITHOUT_PERL_MODULE)
+USE_PERL5= yes
+CONFIGURE_ARGS+= --enable-perl --enable-perl-site-install
+PLIST_SUB+= WITH_PERL=""
+.else
+CONFIGURE_ARGS+= --disable-perl
+PLIST_SUB+= WITH_PERL="@comment "
+.endif
+
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libart-2.0 -I${LOCALBASE}/include/freetype2
LDFLAGS+= -L${LOCALBASE}/lib
@@ -61,8 +70,11 @@ MAN1= bin_dec_hex.1 cdeftutorial.1 rpntutorial.1 rrd-beginners.1 \
rrdgraph_rpn.1 rrdinfo.1 rrdlast.1 rrdresize.1 rrdrestore.1 \
rrdthreads.1 rrdtool.1 rrdtune.1 rrdtutorial.1 rrdupdate.1 \
rrdxport.1 rrdlastupdate.1
+
+.if !defined(WITHOUT_PERL_MODULE)
MAN3= RRDp.3 RRDs.3
MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+.endif
post-extract:
.if defined(NOPORTDOCS)