aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool
diff options
context:
space:
mode:
authorTong LIU <nemoliu@FreeBSD.org>2008-01-23 02:56:54 +0000
committerTong LIU <nemoliu@FreeBSD.org>2008-01-23 02:56:54 +0000
commit06a579296fd0827457733595823c41ebc5dec511 (patch)
tree7be185e9f67e9a2dc788680207893ab3ef85ad39 /databases/rrdtool
parent20e79e8c3bbdf1e4926bdea8f72ec1aedc069539 (diff)
downloadports-06a579296fd0827457733595823c41ebc5dec511.tar.gz
ports-06a579296fd0827457733595823c41ebc5dec511.zip
Notes
Diffstat (limited to 'databases/rrdtool')
-rw-r--r--databases/rrdtool/Makefile2
-rw-r--r--databases/rrdtool/distinfo6
-rw-r--r--databases/rrdtool/files/patch-bindings-Makefile.in18
3 files changed, 12 insertions, 14 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 6fa30e634e23..7e46d49bfad3 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rrdtool
-PORTVERSION= 1.2.23
+PORTVERSION= 1.2.26
CATEGORIES= databases graphics
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/
diff --git a/databases/rrdtool/distinfo b/databases/rrdtool/distinfo
index 3c125af5e984..fa06623b8a1a 100644
--- a/databases/rrdtool/distinfo
+++ b/databases/rrdtool/distinfo
@@ -1,3 +1,3 @@
-MD5 (rrdtool-1.2.23.tar.gz) = dafa161bc9c61e57636a6085c87c1fe8
-SHA256 (rrdtool-1.2.23.tar.gz) = 4b1df00b23a74a1c81734dd274e72e00d8bb29b11e1f3d2938ff87691ece1f0f
-SIZE (rrdtool-1.2.23.tar.gz) = 1061530
+MD5 (rrdtool-1.2.26.tar.gz) = b2c179e2d2ec2a92969648c4ebd382dc
+SHA256 (rrdtool-1.2.26.tar.gz) = 685088c51e63fd9d41387cd39615036baed4460beb87c1ab7127f9325b348b24
+SIZE (rrdtool-1.2.26.tar.gz) = 1080151
diff --git a/databases/rrdtool/files/patch-bindings-Makefile.in b/databases/rrdtool/files/patch-bindings-Makefile.in
index 09af0a5c23ca..fe6cb3333f02 100644
--- a/databases/rrdtool/files/patch-bindings-Makefile.in
+++ b/databases/rrdtool/files/patch-bindings-Makefile.in
@@ -1,26 +1,24 @@
---- ./bindings/Makefile.in.orig Thu May 3 02:06:59 2007
-+++ ./bindings/Makefile.in Tue May 29 03:45:40 2007
-@@ -539,18 +539,18 @@
+--- ./bindings/Makefile.in.orig 2008-01-08 10:36:56.000000000 +0800
++++ ./bindings/Makefile.in 2008-01-08 10:38:18.000000000 +0800
+@@ -544,9 +544,9 @@
all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
- test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
- test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
-- test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+- test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
+ test -f perl-piped/Makefile && cd perl-piped && $(MAKE) pure_install || true
+ test -f perl-shared/Makefile && cd perl-shared && $(MAKE) pure_install || true
+ test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) install || true
- test -d python/build && cd python && env LIBDIR=$(libdir) $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
+ test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
# rules for buildung the ruby module
- ruby:
-- cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS)
-+ cd ruby && $(RUBY) extconf.rb && $(MAKE) EPREFIX=$(exec_prefix)
+@@ -557,7 +557,7 @@
# rules for buildung the pyton module
python:
-- cd python && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
-+ cd python && env LIBDIR=../../src/.libs INCDIR=../../src $(PYTHON) setup.py build
+- cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
++ cd python && env INCDIR=../../src BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
# rules for building the perl module
perl_piped: perl-piped/Makefile