aboutsummaryrefslogtreecommitdiff
path: root/databases/rrdtool
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-02-12 12:58:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-02-12 12:58:21 +0000
commit5350985121163753083d69e64e4477c75cc29dc1 (patch)
treebe8e3fdc15e8391a48c6a5131e9936111190c61e /databases/rrdtool
parent3e9b0c306ddfd3428a0cb89f93d45275d5bf25f5 (diff)
downloadports-5350985121163753083d69e64e4477c75cc29dc1.tar.gz
ports-5350985121163753083d69e64e4477c75cc29dc1.zip
Notes
Diffstat (limited to 'databases/rrdtool')
-rw-r--r--databases/rrdtool/Makefile7
-rw-r--r--databases/rrdtool/distinfo6
-rw-r--r--databases/rrdtool/files/patch-bindings-Makefile.in27
-rw-r--r--databases/rrdtool/files/patch-doc-Makefile.in8
-rw-r--r--databases/rrdtool/files/patch-examples-Makefile.in10
-rw-r--r--databases/rrdtool/files/patch-src-rrd_open.c10
-rw-r--r--databases/rrdtool/pkg-plist17
7 files changed, 47 insertions, 38 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index f4b9a002ce8c..62c61b360852 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rrdtool
-PORTVERSION= 1.3.9
+PORTVERSION= 1.4.2
CATEGORIES= databases graphics
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/
@@ -19,7 +19,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
pangocairo-1\.0.0:${PORTSDIR}/x11-toolkits/pango
-CONFLICTS= rrdtool-1.0*
+CONFLICTS= rrdtool-1.0* rrdtool-1.2*
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
@@ -87,7 +87,7 @@ CFLAGS:= ${CFLAGS:N-ffast-math}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= bin_dec_hex.1 cdeftutorial.1 rpntutorial.1 rrd-beginners.1 \
- rrdbuild.1 rrdcgi.1 rrdcreate.1 rrddump.1 rrdfetch.1 rrdfirst.1 \
+ rrdbuild.1 rrdcached.1 rrdcgi.1 rrdcreate.1 rrddump.1 rrdfetch.1 rrdfirst.1 rrdflushcached.1 \
rrdgraph.1 rrdgraph_data.1 rrdgraph_examples.1 rrdgraph_graph.1 \
rrdgraph_rpn.1 rrdinfo.1 rrdlast.1 rrdresize.1 rrdrestore.1 \
rrdthreads.1 rrdtool.1 rrdtune.1 rrdtutorial.1 rrdupdate.1 \
@@ -99,6 +99,7 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.endif
post-extract:
+ @${REINPLACE_CMD} -e 's/^POD3/#POD3/' ${WRKSRC}/doc/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/install-idocDATA install-ihtmlDATA//g' \
-e 's/^ cd .* rrdtool.html index.html/ #/' \
diff --git a/databases/rrdtool/distinfo b/databases/rrdtool/distinfo
index 018179ca87d5..dc5f1116d5e3 100644
--- a/databases/rrdtool/distinfo
+++ b/databases/rrdtool/distinfo
@@ -1,3 +1,3 @@
-MD5 (rrdtool-1.3.9.tar.gz) = 37db5959b2eff90ed8f8a0178bba5d6b
-SHA256 (rrdtool-1.3.9.tar.gz) = 9e8757192a56e006d7c593970aca4850a05fa34807a5092d1d132da8f48e0108
-SIZE (rrdtool-1.3.9.tar.gz) = 1189442
+MD5 (rrdtool-1.4.2.tar.gz) = 9318d3b4016dd9dd9897f1eac7548032
+SHA256 (rrdtool-1.4.2.tar.gz) = e55ebe13b16515a275185229a93ee1fc266010a9e3c6b05b229a1530695311cb
+SIZE (rrdtool-1.4.2.tar.gz) = 1355269
diff --git a/databases/rrdtool/files/patch-bindings-Makefile.in b/databases/rrdtool/files/patch-bindings-Makefile.in
index fe6cb3333f02..daa1de9eb748 100644
--- a/databases/rrdtool/files/patch-bindings-Makefile.in
+++ b/databases/rrdtool/files/patch-bindings-Makefile.in
@@ -1,24 +1,25 @@
---- ./bindings/Makefile.in.orig 2008-01-08 10:36:56.000000000 +0800
-+++ ./bindings/Makefile.in 2008-01-08 10:38:18.000000000 +0800
-@@ -544,9 +544,9 @@
+--- ./bindings/Makefile.in.orig 2009-12-01 23:10:30.000000000 +0000
++++ ./bindings/Makefile.in 2009-12-01 23:14:10.000000000 +0000
+@@ -679,9 +679,9 @@
all-local: @COMP_PERL@ @COMP_RUBY@ @COMP_PYTHON@
install-data-local:
-- test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
-- test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
-- test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
-+ test -f perl-piped/Makefile && cd perl-piped && $(MAKE) pure_install || true
-+ test -f perl-shared/Makefile && cd perl-shared && $(MAKE) pure_install || true
-+ test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) install || true
- test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
+- $(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
+- $(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
+- $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
++ $(AM_V_GEN)test -f perl-piped/Makefile && cd perl-piped && $(MAKE) pure_install || true
++ $(AM_V_GEN)test -f perl-shared/Makefile && cd perl-shared && $(MAKE) pure_install || true
++ $(AM_V_GEN)test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(DESTDIR)$(exec_prefix) install || true
+ $(AM_V_GEN)test -d python/build && cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py install --skip-build --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
- # rules for buildung the ruby module
-@@ -557,7 +557,7 @@
+ # rules for building the ruby module
+@@ -692,7 +692,8 @@
- # rules for buildung the pyton module
+ # rules for building the pyton module
python:
- cd python && env BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
+ cd python && env INCDIR=../../src BUILDLIBDIR=../../src/.libs $(PYTHON) setup.py build_ext --rpath=$(libdir) && env LIBDIR=../../src/.libs $(PYTHON) setup.py build
++
# rules for building the perl module
perl_piped: perl-piped/Makefile
diff --git a/databases/rrdtool/files/patch-doc-Makefile.in b/databases/rrdtool/files/patch-doc-Makefile.in
index 844bcc780935..4ad05f5a748e 100644
--- a/databases/rrdtool/files/patch-doc-Makefile.in
+++ b/databases/rrdtool/files/patch-doc-Makefile.in
@@ -1,9 +1,9 @@
---- doc/Makefile.in.orig Thu May 3 12:26:06 2007
-+++ doc/Makefile.in Thu May 3 12:26:35 2007
-@@ -239,9 +239,9 @@
+--- ./doc/Makefile.in.orig 2009-12-01 23:14:57.000000000 +0000
++++ ./doc/Makefile.in 2009-12-01 23:18:22.000000000 +0000
+@@ -327,9 +327,9 @@
# what should go into the distribution
- EXTRA_DIST = $(POD) $(HTML) $(MAN) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
+ EXTRA_DIST = $(POD) $(POD3) $(HTML) $(MAN) $(MAN3) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd rrdgraph_libdbi.pod rrdlua.pod
-idocdir = $(RRDDOCDIR)/txt
+idocdir = $(datadir)/doc/rrdtool/txt
idoc_DATA = $(POD) $(TXT)
diff --git a/databases/rrdtool/files/patch-examples-Makefile.in b/databases/rrdtool/files/patch-examples-Makefile.in
index a44b80f7eba4..fd6514a2c127 100644
--- a/databases/rrdtool/files/patch-examples-Makefile.in
+++ b/databases/rrdtool/files/patch-examples-Makefile.in
@@ -1,8 +1,8 @@
---- examples/Makefile.in.orig Thu May 3 12:27:17 2007
-+++ examples/Makefile.in Thu May 3 12:27:41 2007
-@@ -219,7 +219,7 @@
- target_os = @target_os@
- target_vendor = @target_vendor@
+--- ./examples/Makefile.in.orig 2009-12-01 23:18:52.000000000 +0000
++++ ./examples/Makefile.in 2009-12-01 23:19:10.000000000 +0000
+@@ -352,7 +352,7 @@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = rrdcached
EXTRA_DIST = cgi-demo.cgi.in
-examplesdir = $(pkgdatadir)/examples
+examplesdir = $(datadir)/examples/rrdtool
diff --git a/databases/rrdtool/files/patch-src-rrd_open.c b/databases/rrdtool/files/patch-src-rrd_open.c
index af5bc71a9e5b..25ec5cd28ab8 100644
--- a/databases/rrdtool/files/patch-src-rrd_open.c
+++ b/databases/rrdtool/files/patch-src-rrd_open.c
@@ -1,12 +1,12 @@
---- src/rrd_open.c.orig 2008-06-30 12:52:29.000000000 +0800
-+++ src/rrd_open.c 2008-06-30 12:53:14.000000000 +0800
-@@ -388,9 +388,6 @@
+--- ./src/rrd_open.c.orig 2009-12-01 23:21:20.000000000 +0000
++++ ./src/rrd_open.c 2009-12-01 23:22:41.000000000 +0000
+@@ -552,9 +552,6 @@
int ret;
#ifdef HAVE_MMAP
-- ret = msync(rrd_file->file_start, rrd_file->file_len, MS_ASYNC);
+- ret = msync(rrd_simple_file->file_start, rrd_file->file_len, MS_ASYNC);
- if (ret != 0)
- rrd_set_error("msync rrd_file: %s", rrd_strerror(errno));
- ret = munmap(rrd_file->file_start, rrd_file->file_len);
+ ret = munmap(rrd_simple_file->file_start, rrd_file->file_len);
if (ret != 0)
rrd_set_error("munmap rrd_file: %s", rrd_strerror(errno));
diff --git a/databases/rrdtool/pkg-plist b/databases/rrdtool/pkg-plist
index 3e35dd3dfc10..7e15d210f74a 100644
--- a/databases/rrdtool/pkg-plist
+++ b/databases/rrdtool/pkg-plist
@@ -1,16 +1,18 @@
-bin/rrdtool
+bin/rrdcached
bin/rrdcgi
+bin/rrdtool
bin/rrdupdate
+include/rrd.h
+include/rrd_client.h
+include/rrd_format.h
lib/librrd.a
lib/librrd.la
lib/librrd.so
-lib/librrd.so.4
+lib/librrd.so.5
lib/librrd_th.a
lib/librrd_th.la
lib/librrd_th.so
-lib/librrd_th.so.4
-include/rrd.h
-include/rrd_format.h
+lib/librrd_th.so.5
libdata/pkgconfig/librrd.pc
%%WITH_PERL%%%%SITE_PERL%%/RRDp.pm
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RRDp/.packlist
@@ -22,3 +24,8 @@ libdata/pkgconfig/librrd.pc
%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/RRD.so
%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/RRDp
%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/RRDs
+share/rrdtool/examples/rrdcached/RRDCached.pm
+share/rrdtool/examples/rrdcached/rrdcached-size.pl
+@dirrm share/rrdtool/examples/rrdcached
+@dirrm share/rrdtool/examples
+@dirrm share/rrdtool