aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-bdb
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-01-03 02:28:49 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-01-03 02:28:49 +0000
commit4c00187cd403e0e73bd23374a75f949a9c1cb983 (patch)
treedabbd68a15d23ede858a9a56df50a35ba2f7c5e8 /databases/ruby-bdb
parent5072887128b89e0686a04ebab56bb971b848996b (diff)
Convert to staging, and fix a few quirks along the way:
- fix shebang lines in example scripts - strip the installed bdb.so file
Notes
Notes: svn path=/head/; revision=338518
Diffstat (limited to 'databases/ruby-bdb')
-rw-r--r--databases/ruby-bdb/Makefile34
1 files changed, 28 insertions, 6 deletions
diff --git a/databases/ruby-bdb/Makefile b/databases/ruby-bdb/Makefile
index 89209a4c531c..0fcfd82cd88a 100644
--- a/databases/ruby-bdb/Makefile
+++ b/databases/ruby-bdb/Makefile
@@ -35,8 +35,29 @@ EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/bdb.so
PORTDOCS= *
PORTEXAMPLES= *
+USES= shebangfix
+SHEBANG_FILES= examples/record.rb \
+ examples/recno.rb \
+ examples/zeroc.rb \
+ examples/txn.rb \
+ examples/queue.rb \
+ examples/cats.rb \
+ examples/log.rb \
+ examples/cursor.rb \
+ examples/func.rb \
+ examples/replication/mgr/b.rb \
+ examples/replication/base/op.rb \
+ examples/replication/base/cl.rb \
+ examples/replication/base/b.rb \
+ examples/replication/base/ma.rb \
+ examples/replication/base/mc.rb \
+ examples/join.rb \
+ examples/basic.rb \
+ examples/lock.rb
+
+
+NEED_ROOT= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
@@ -51,14 +72,15 @@ post-build:
.endif
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}/bdb.so
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/doc
- (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR})
- (cd ${WRKSRC}/docs/doc && ${COPYTREE_SHARE} . ${DOCSDIR}/doc)
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/doc
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC}/docs/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/doc)
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/
- (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR} "! -empty")
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR} "! -empty")
.endif
regression-test: build